Slicer and video projector issue

Hi all,
maybe it is not a proper “slicer related” question/issue, but maybe you can help me.

I connected my laptop (arch Linux/gnome) to a video projector to show something in Slicer.
In order to make the Slicer windows more visible, I edited the resolution of the video projector.

Now, the problem is that if I connect the laptop on a second screen I see Slicer zoomed, even if it is not the video projector!
The even stranger thing is that this happens only with my office second monitor…on my home screen this does not happen!

I tried to use another Slicer nightly version but nothing changes.
Any tips for fixing the problem?

Thanks a lot!

Can you post a screenshot of how Slicer is zoomed in? Are the fonts larger, too, or just the application window does not fit on the screen?

How is it with latest Slicer Stable Release?

You can also adjust these environment variables to customize application scaling:

Does erasing Slicer.ini fix the issue?

Other users reported issues with automatic restoring of window position after disconnecting a screen. We could try to apply additional checks for window restore (see here), which may help.

We could also check if a specific key is held down during startup (e.g., Shift key is depressed, using QGuiApplication::queryKeyboardModifiers()), and if yes, then do not restore previously saved window position. Would we want this? (@pieper, @cpinter, @jcfr)

Holding shift during startup to bypass previous settings sounds harmless in general and maybe super useful on special occasions.

Would you bypass all settings or just skip restoring the window position?

It seems there could be other settings that would break things at startup, so a general way to bypass would be handy. But maybe the window position issue is so common it deserves a dedicated solution? I don’t know because this does not happen for me.

Actually wouldn’t running with the --disable-settings --keep-temporary-settings options fix the problem?

From Slicer --help

  --disable-settings                            Start application ignoring user settings and using new temporary settings.
  --keep-temporary-settings                     Indicate whether temporary settings should be maintained.

Yes, disable+keep settings does the same, but finding the Slicer executable, starting a terminal at that location, and copy-pasting a command there is too hard for many users.

Maybe we could add a shortcut that would launch Slicer with these options (not too hard to set it up in the Windows installer but I don’t know if it is available on Mac and Linux).

We could also provide a “Slicer maintanance tool” (maybe as a separate download), which would allow cleaning up Slicer.ini and version-specific Slicer-NNN.ini files, cleaning up Slicer installations, find/view logs, etc.

Thanks for the tips.
The screen is in my office (at home with a different second screen it is ok), so I’ll be able to run the tests in the next days.
I’ll update you asap!


1 Like

Yes, a diagnostic tool / mode would make sense. It’s easy to bundle a shell script with linux. For mac we’d probably need a second app - instructions to open the terminal would probably be easier.

Hi all,
I ran the test, the options suggested didn’t fix the problem.

I attach a screenshot.

Thank you.