Slicer Black screen on opening software

Operating system: Windows 10 Home
Slicer version: 4.13.0
Expected behavior: Starting with Slicer 3d
Actual behavior: A blank black screen is appearing
Pls help , i am unable to see any icons/ or options to upload data
Just a blank black screen is appearing , i tries reinstalling , also the previous version same output.

This typically happens if the computer does not have sufficient graphics capabilities to run Slicer. What CPU and graphics does this computer has?

Hi Lassoan,
Thanks for the response
CPU : Intel I5
Graphics - Intel (R) , Shared memory 2GB

It worked well for the first time immediately after download. Later on when i open after closing is appearing like this.

What is the exact CPU model? Intel Core i5-…? (you can find it in System Information)

CPU Details
image
Graphic Card Details
image

This is a 4th generation Intel CPU that was released in 2014. We need to balance between compatibility between old hardware and achieving good performance on modern hardware. As a result, we target 3D Slicer to run on computers that are not older than 5 years. See some more details here.

You either need to upgrade to a newer computer or rent a more recent computer from a cloud provider.

Ok thank you ,by any chance will it work if i download older version of slicer ?

You can find old Slicer versions if you click the “access older releases” on the Slicer download page.

However, new versions of Slicer are so much better that I cannot recommend using older versions.

  • If you consider your time valuable: the time that you save by using a more recent Slicer version is worth more than the cost of buying a computer (you can buy a used desktop computer that can run Slicer for about $500)
  • If you consider your time valuable but don’t want to buy a new computer right now (because you want to use Slicer for just a few hours or don’t want to spend money on computer hardware): you can rent a computer by the minute from a cloud provider.
  • If you don’t consider your time not valuable: you can use free cloud services, which are slower and not as convenient, but should still be usable (for example Binder, as explained in the Getting started page). You can click here to run a 1-year-old version of Slicer, for free, on the cloud. (you can configure newer versions, too)

Thanks a lot for the support lassoan. :slight_smile: since I am using it for a study purpose project, I will try to rent from the cloud as recommended

Wrong answers! I solved the black home screen by launching the app with “Run as Administrator”. It worked smoothly. You can also go to program’s PROPERTIES/ Shortcut/ Advanced…/ Run as Administrator. This way you don’t have to click “Run as Administrator” each time.

Thanks for taking the time for letting other users know what worked for you. It is important to note that the answers above are not wrong, but of course there may be many different reasons behind the same symptom and not all solution work for everyone.

To better understand the impact of running Slicer as an administrator (on old Windows versions?), I’ve posted some questions to clarify - see here: