Slicer not opening anymore

I am using a Windows desktop with plenty of RAM (64gb, no other programs open). Slicer worked fine until 20minutes ago when it crashed my computer when opening up a relatively small dataset. Computer restarted and now I am unable to open slicer.

When I open the program I get the initial window and the program shows up in the task manager, then a few seconds later the status in task manager changes to “suspending” and then closes out.

I have uninstalled and reinstalled slicer and am using latest stable version. Other programs appear to run fine on the computer. Any ideas?

So a ‘fun’ bug I noticed is that Slicer has trouble opening on non-primary monitors. I believe it is closely related to this issue, or some variation of it. It’s not you. It’s OpenGL.

An experiment to verify this is to unplug the second monitor or any other non-primary monitor, open Slicer, and see if it works. You may have to try moving it if it’s starting off-screen.


I think this was some obscure issue related to my PC. I got another BSOD when the computer restarted it went into recovery mode. After restarting again slicer worked fine. Who knows.