Slicer wiki edit permissions reset

I tried to edit, and discovered that my permissions to edit Slicer wiki content are gone. Is this expected? Is Slicer wiki in “read only” mode? @mhalle do you know what is going on?

image

@fedorov What was the exact URL you tried?

I can edit https://www.slicer.org/wiki/Documentation/Nightly/ScriptRepository page (just tried) and I can see that others have edited Slicer wiki pages successfully, too.

@freephile

I wanted to add a tutorial link to this page: https://www.slicer.org/wiki/Documentation/Nightly/Modules/PkModeling?veaction=editsource

I was able to edit https://www.slicer.org/wiki/Documentation/Nightly/ScriptRepository, but not the page I linked above.

This is very confusing.

I was able to edit the PkModeling page using the link you provided above.

Hopefully @freephile will be able to explain what is going on.

@fedorov I can see no reason why you would be prevented from editing that page… except that maybe your session timed out. You ARE a member of the ‘users’ group and therefore should be able to edit most pages in the wiki. I reviewed the configuration of permissions and groups in the wiki. I also reviewed the settings (protection) for that particular page.

Can you please try again and let me know the outcome?

Thanks,

Greg

I tried several times again, and it worked. I think what was happening is that somehow wiki was logging me out without indication in the user interface because of some action I did in the interface. I don’t want to spend time debugging this and making a screencast. To cut it short, I was able to update the page. Thank you.

1 Like