SlicerFab - Incomplete Export of Volume


I’m fairly new to the Slicer community and am using SlicerFab to export my volume rendering to a stack of PNG’s.

Currently the PNG’s appear to just be multiple copies of one “layer”. It also stops after exporting only a small portion of my model. I’ve verified under the Volume Rendering module that the ROI contains the full model. I have also tried adjusting the layer thickness, but so far this only results in more/fewer of the copies being generated.

I’m currently using 3D Slicer 4.11.0-2019-11-19
I’d appreciate any troubleshooting tips you might have for me.

Thank you!

Hi -

Thanks for the report - I’m not sure how much that module gets used/tested, but I just tried on my local build and it worked. It’s very slow at high resolution and the image may not look much different, but if you watch the output directory you should see files being written.

I tested by downloading the MRHead from SampleData, turning on Volume Rendering, and then exporting bitmaps at 100dpi and 1mm layer thickness. Does that same process work for you? Does it stop working at higher resolution or behave differently with your data?

Thanks for your quick reply Steve.

I tried the process you described, exporting at 100 dpi and 1mm layer thickness. From the bitmap generator window I see the ROI moving through my model and the PNG’s being generated as expected, but when I view the images they all look the same.

The model has quite a few different colours throughout, so the images should all look pretty unique. When I try a larger layer thickness it creates PNG’s of a different section of my model, but those PNG’s also appear identical to each other.

May I ask where I can find the sample data you used?
Thank you again.

Thanks for testing - I doublechecked and my pngs are all different and look correct. A few examples below.

I used the SampleData module (you can get to it via the File menu). Just click the MRHead button and it should download and show in Slicer.

Try with the latest Slicer preview release. 3 months is very old for a Slicer Preview Release (we fix and improves things almost every day).

Thanks Steve and Andras for your help.

I realized the data I was using was actually a segmentation node and not a volume node, I exported them to labelmaps and that fixed my problem. I am also now using the latest Slicer release. Thanks for your patience.