SlicerJupyter prevents Slicer from opening

Hi, I’m on a Macbook Pro M2. I was using Slicer 5.7 Preview from some time in April (sorry, I deleted it since and forget which date exactly) and after installing the SlicerJupyter extension it requested a restart, quit unexpectedly and then crashed again when loading back up. After this, it would crash every time I tried to start Slicer.

Then I downloaded 5.6.2 stable and selected SlicerJupyter among some other extensions and the same behavior occurred. I can no longer open the application without it crashing. The log file generated by Apple is here.

Then I tried with the 5.7 2024-05-13 preview build and only selected SlicerJupyter. Same behavior (log is here).

Please let me know if there is any other information you’d like me to provide and if there’s anything I can do to potentially fix this other than waiting for a new version of SlicerJupyter.

Looking at some older posts, I tried deleting ~/.config/ to see if that would help but it didn’t. I also saw in that file there were some Slicer-generated logs:




These didn’t show any errors and looked like:

[DEBUG][Qt] 16.05.2024 08:58:00 [] (unknown:0) - Session start time .......: 20240516_085800

[DEBUG][Qt] 16.05.2024 08:58:00 [] (unknown:0) - Slicer version ...........: 5.6.2 (revision 32448 / f10cd8c) macosx-amd64 - installed $

[DEBUG][Qt] 16.05.2024 08:58:00 [] (unknown:0) - Operating system .........: macOS / 14.4.1 / 23E224 / UTF-8 - 64-bit

[DEBUG][Qt] 16.05.2024 08:58:00 [] (unknown:0) - Memory ...................: 16384 MB physical, 0 MB virtual

[DEBUG][Qt] 16.05.2024 08:58:00 [] (unknown:0) - CPU ......................: Apple M2 Pro, 10 cores, 10 logical processors

[DEBUG][Qt] 16.05.2024 08:58:00 [] (unknown:0) - VTK configuration ........: OpenGL2 rendering, TBB threading

[DEBUG][Qt] 16.05.2024 08:58:00 [] (unknown:0) - Qt configuration .........: version 5.15.8, with SSL, requested OpenGL 3.2 (core profi$

[DEBUG][Qt] 16.05.2024 08:58:00 [] (unknown:0) - Internationalization .....: disabled, language=

[DEBUG][Qt] 16.05.2024 08:58:00 [] (unknown:0) - Developer mode ...........: disabled

[DEBUG][Qt] 16.05.2024 08:58:00 [] (unknown:0) - Application path .........: /Applications/

[DEBUG][Qt] 16.05.2024 08:58:00 [] (unknown:0) - Additional module paths ..: Extensions-32448/QuantitativeReporting/lib/Slicer-5.6/qt-s$

Hi @Justin_Kirby - Depending on what python packages you install, maybe through extensions, you may get conflicting versions of packages like SimpleITK due to mismatches in the requirements specification.

Can you try doing a fresh install and only installing Jupyter to see what happens?

Hi @pieper , both of the last two tests were “fresh installs” of Slicer, but installing the other extensions in that second test (with 5.6.2 stable) may have created potential confusion about what the problem was, so in the third test with the preview build I didn’t install anything other than SlicerJupyter after the fresh installation.

Okay, thanks, that clarifies things. I don’t use SlicerJupyter myself so I’m not sure what else to suggest. Maybe one of the original developers or other users have suggestions.