Smoothing multiple segments at once

Doing a segmentation of jejunum. When I include the whole jejunum in one segment it “melts together”:

So then I do it as separate segments. Works better but I get “seams” between segments.\

I overlap the segments by a bit and it makes it better …but still there… not a deal breaker but curious if anyone has any ideas to make the jejunum look like one continuous tube

You can smooth out these tiny seams using Smoothing brush locally, without affecting any other parts of the segmentation.

I can not make this work. When I try to smoothen the junction between two segments the brush only affects the selected segment?

Joint smoothing method is not available for the smoothing brush (when you attempt to do it you should see the “Smoothing brush is not available for joint smoothing method” message).

Instead, if you want to apply joint smoothing in a certain region only, you need to use masking settings:

  1. Specify the region that will be smoothed
  • Create a new segment, set its name to Mask
  • Switch to Paint effect
  • Allow overlap between segments: in Masking settings (at the bottom) set Modify other segmentsAllow overlap
  • Paint the region you want to smooth (you can enable Sphere brush option to paint a larger region more quickly)
  1. Apply joint smoothing restricted to the region designated by the “Mask” segment
  • Switch to Smoothing effect
  • Hide the Mask segment (this will exclude it from the smoothing, as joint smoothing will be only applied to visible segments)
  • Restrict the effect to the designated region: set Masking / Editable areaInside Mask
  • Select Smoothing methodJoint smoothing and click Apply