Strange air pockets in segmentation editor, can't mark air pockets as apart of segmentation.

Hi everyone,

I seem to have ran into a bug, when using segmentation editor to segment a head in MRI data, I get these air pockets that are not included in segmentation. The goal is to use this segmentation to construct a model of the head with no open air pockets.

Here is an image of what I mean, you will se a dark section with no green tent. That is the undesirable air pockets. Desired output is the entire head being added to the segmentation including regions where the air pockets exist.

This is a photo of what the segmentation looks like in 3d, As you can see there is indents where these air pockets exist.

I am confused on how to remove these air pockets, anything helps!

Thank you,

You have selected an intensity range in masking settings that does not include the intensity of air. You can disable “Editable intensity range” checkbox to allow painting everywhere.

Also, If you don’t want to manually paint them in, you can try the Surface Wrap Solidify extension to maintain the surface but fill the cavities

1 Like