Segmentation Editor - How to disable painting on adjacent slices?

I am working on a project where we are segmenting lesions from an MRI using the paint tool from the Segment Editor module. We are using a large brush size along with a threshold so only pixels within a certain range are included in the segmentation.

My problem is that I want the segmentation to be only in 2d (i.e. just affecting the pixels on the current slice of the volume). For example, if I do a threshold paint on slice 10 of the MRI, I don’t want it to paint any of the pixels on slice 9 or 11.

I figured there would be a way to disable this, but I can’t seem to find the option.

I am using the following version of slicer: 4.9.0-2017-11-10 r26630

By default, paint effect only paints on the current slice. Have you enabled “sphere” brush option?

Thanks for the reply. I was thinking that option might be related.

I tried enabling and disabling that brush option, but the adjacent slices are still painted. I tried using both the stable and nightly builds. I am not sure if it would matter or not, but I am running linux - I did not try on windows.

Either way, thanks for the tip. I will close out of the application and start fresh and retest to make sure it was not user error.

Lead Data Scientist
NLP Logix, LLC
4215 Southpoint Boulevard|Suite 160
Jacksonville, FL 32216
www.nlplogix.comhttp://www.nlplogix.com
https://www.nvidia.com/en-us/gtc-dc/

If the acquisition was tilted you may need to rotate to volume plane (click the “pushpin” icon in the top-left corner of the slice view, then click the double-arrow button on the left, then the “Rotate to volume plane” icon appears):

image

Here’s an example drawing on the original slice (patient space)

And here the paint stroke on the right is after rotating the red slice into the acquisition plane and only one plane is painted in the other views.

4 Likes

That was it. Thanks for the answer (with pictures). I would not have figured this out otherwise.

Recent versions of Slicer now show a warning button (with an exclamation mark) if any of the slice viewers are not aligned with the current segmentation axes. Click that button to snap each slice view to nearest segmentation axis.