Transparent segments viewed in 3D clipped by volume renderer?


(Hollister Herhold) #1

Can transparent segments be viewed in 3D along with the volume renderer? I searched through similar topics but didn’t find anything exactly like this.

Quick list of steps:

  1. Make a segment
  2. Enable viewing in 3D
  3. Turn on volume rendering
  4. Crop volume in volume rendering so segment “sticks out”
  5. Change segment opacity to something other than 1.0
  6. Segment disappears, except where volume is not in background - if you rotate around, segment becomes visible.

This is on the latest nightly (Feb 28), on both Mac and PC, and I have depth peeling enabled.

Any ideas? Thanks!!

-Hollister


(Andras Lasso) #2

For me it works as you describe (segment disappears) if depth peeling is disabled but works perfectly if depth peeling is enabled.

Could you show a screen capture video of what you do?


(Hollister Herhold) #3

Hmm. I just re-did my scene from scratch after turning on depth peeling and it works properly (with transparency). Is depth peeling a setting in the scene’s MRML file, and it’s not properly set in my original (not working) file?

Thanks for the help!

-Hollister


(Andras Lasso) #4

Yes, UseDepthPeeling flag is saved in the scene. It might be possible that if you enable it later then not everything is initialized correctly.


(Hollister Herhold) #5

Thanks, Andras.

Not to nit-pick, but that’s a little confusing - setting depth peeling is in “Application Settings”, which I would take to mean application-wide, not per-file. Would it make more sense to move depth peeling to Volume Rendering or Segment Editor?

I guess the problem is that it’s an application setting, not a module setting, so there isn’t one good place to put it. Maybe a note by the depth peeling check box saying the setting is saved in scene files? (I’m happy to add that if agreed upon.)


(Andras Lasso) #6

You can set default view settings in application settings, which is applied to new views.

image

You can change the current settings in the view controller.

image


(Hollister Herhold) #7

Got it, ok - that makes sense.

“Problem between chair and keyboard”, as they say.

Thanks!

-Hollister