Ubuntu 18.04 scaling small issues

Hi all,

I personally don’t use 4k monitors, however I have just tried running Slicer in a 4k monitor on ubuntu 18.04 with the scaling option (recently added in ubuntu, 200%).

This is the result:
Screenshot-20180418115402-3966x2107

it kind of works, but many icons are of different sizes and at the end it does not look too good. I was wandering if this is just an issue with ubuntu, how it does the scaling (it looks that it scales only the text and the relative GUI) or do you experience this also in windows? (on mac everything seems working on retina display with scaling).

Thanks for testing this. If scaling has just been added to Ubuntu then probably it will take some time for Qt developers to take advantage of it and use it to optimize display.

I believe 18.04 ships with Wayland as an optional graphics stack, so if you have some time to rebuild, it might be worth enabling QtWayland in your qt build and then see if Slicer runs at all/better:

https://wiki.qt.io/QtWayland#Run_Qt_applications_as_Wayland_clients

(I’ve read somewhere that hidpi support is better in wayland – and X11 isn’t getting much effort there)

yeah, most likely will take at least another distro release in time for having the scaling sorted out in linux (at least in ubuntu).

I tried to use Wayland in ubuntu 17.10. However it was very bugged, specifically there was almost no support in the nvidia driver for wayland. On fresh install of ubuntu 18.04, the default is back to Xorg and I can’t even go back to wayland (maybe it is a bug, there is no gear option at login screen). It seems, unfortunately, we will have to wait at least the next release to have decent wayland support.

I had the same issue. I changed the font size from Slicer settings.

I did some testing today using Slicer binaries 8.4.1, 4.10.0 and nightly build 4.11.0 2018-10-23. It seems 4.8.1 adapts better to different monitors. I think the problem is related to Slicer version as I am using the same hardware, system, and settings. Is it possible to have the same behavior in recent versions?

Slicer 4.8 used Qt 4.x and 4.10 uses Qt 5.x and there appears to be some debugging to do related to handling of various ‘retina’ and other multiresolution monitor support (the hardware and OS features are continuing to evolve, I’m sure). For example my recent mac build is completely screwed up with the latest Qt and macOS.

This will require some experimentation on the developer side, but also we’ll need a lot of people to test and provide feedback as we try different settings.

Slicer 4.8 used Qt 4.x and 4.10 uses Qt 5.x

Thanks for the info. I am happy to help with the testing. BTW, I tried building 4.10 with Qt4 and it seems there is no scaling problem.

Qt4 did not do any scaling, therefore issues with high-DPI screens are completely different on Qt4 and Qt5.