"Unable to open OpenCV video device" error when streaming an URL using PLUS Toolkit


  1. I am trying to stream an URL using the following PLUS config file (I want to send the video from the streaming to SlicerIGT):

When I lauch the server, I get the following error:

|ERROR|5539.549000|SERVER> Unable to open OpenCV video device.| in :\D\PSNP64b\PlusLib\src\PlusDataCollection\OpenCVVideo\vtkPlusOpenCVCaptureVideoSource.cxx(193)
|ERROR|5539.582000|SERVER> VideoDevice: Cannot connect to data source, ConnectInternal failed| in :\D\PSNP64b\PlusLib\src\PlusDataCollection\vtkPlusDevice.cxx(1147)
|ERROR|5539.583000|SERVER> Unable to connect device: VideoDevice.| in :\D\PSNP64b\PlusLib\src\PlusDataCollection\vtkPlusDataCollector.cxx(353)
|ERROR|5539.584000|SERVER> Datacollector failed to connect to devices| in :\D\PSNP64b\PlusLib\src\PlusServer\Tools\PlusServer.cxx(106)

I have tried to stream using VLC media player and it worked with that URL, so I don’t know why it does not work with PLUS.

  1. I have also tried to select a file from my computer so that ‘VideoURL’ in the config file is the path to my file (I just modified that line from the config file), which is an .mkv file. It did not display any error but reproduced the video very fast and apparently not taking into account the specified acquisition rate.

Which option is better? What am I missing?

Thanks in advance!