Using monailabel on masks not created using monailabel

Hello. I am trying to use the train feature of monailabel using a dataset with masks that were created outside 3dslicer. Would I need to create a datastore_v2 file for this case?
For the folder structure, I have a folder with the mra data, and in that folder, I have a folder called labels in which there is a folder called final with all the masks.
Is this correct?


I tried running that, and I got a torch size error. Here is the error I am getting:

Is there something wrong with the data I am giving?

Sorry for the error, I am not officially in the commercial MONAILabel NVIDIA team, but try to help support ML in the Slicer forum, which is a secondary help source. There is also a MONAI GitHub and the GitHub of MONAILabel, which you could feed with an “issue”.
But let us first look at your system. Please provide system information including your GPU data. And please invest some patience and endurance.

You could also start with the “spleen” segmentation model to get experience with the process of MONAILabel.

A good Youtube linke of @diazandr3s is here.

1 Like

I am using a 2070 GPU with an i7 8700k CPU. I was able to run and train MONAILabel before on a different dataset, but I am only having an issue now, so I am confused on what the issue is.

1 Like

Please compare the file sizes of your both datasets, maybe reduced file numbers of your new dataset. What is the file format of the single files ? NIFTI or MRB or NRRD or somehow importing DICOM ?
Also compare a not working data file when opening “Volumes” and “Volume Information” in 3D Slicer.
Make a screenshot like this and post it here. Take care not to include any non-anonymized data when you post things on 3D Slicer discourse.
An example of the sample dataset of 3D Slicer is here:

Please provide one screenshot from working and one from not working dataset.

Hello, just to clarify the new dataset I was trying to train is bigger than the one that worked. The files are NIFTI files with .nii.gz endings.

Here is a screenshot from the dataset that is working:

Here is a screenshot from the dataset that is not working:

Thank you for assisting me.

This may cause the problem, and the IJK to RAS matrix and the image spacings are different in the non-working files. Your 8 GB video RAM is on the lower end of system requirements for training. We recommend 12 - 24 GB video RAM.
But great technical experience have @diazandr3s and @lassoan, who may also comment on the problem. But please accept a possible delay of their response due to the holiday season. I will experiment a bit and if I find something new I will post it here.

And please describe the way you installed MONAILabel. Have you followed this How-To ? Are you using Windoes (which) or Linux or WSL on Windows ?

1 Like

I am running this on Windows 10. For the matrices, shouldn’t it be fine as long as the image and the mask match?

1 Like

This discussion is being moved to the MONAI Label repo. Here: MONAILabel torchsize error when training with 3d slicer · Issue #1613 · Project-MONAI/MONAILabel · GitHub