Using slicer behind proxy

We are behind a corporate proxy, and more and more this creates issues with sample set downloads though slicer. E.g., this is the contents of the mrhead.nrrd when I use the sample data:
This windows workstation is already configured to use specified proxy. Is there way to set this proxy explicitly from

Proxy Server Use Required
Internet Access requires the use of a web proxy server.

Please configure your web browser to automatically detect web proxy settings.
For assistance, please refer to the Proxy Configuration page.

In some cases it may be necessary to re-apply the settings. To do this in Internet Explorer, go in to Tools, Internet Options, Connections, LAN Settings. Uncheck "Automatically detect settings", hit Ok, then go back in and re-check the box.

For additional questions, please contact Service Desk at x71111. </HT

Is your http_proxy environment variable set? I’ve never had to use a proxy, but from what I can tell that’s what’s needed so that the proxy would be used in SampleData.

I never had to set the http_proxy on windows boxes, only on Linux. But I can give it a try and report back.

Worked great. Thank you!