Viewing GE vivid e95 exported dicoms

Hi there, I installed SlicerHeart extension and tried to import dicom files exported from the GE vivid e95 machine. It can’t import last volumes and gives the following error:

[Python] Traceback (most recent call last):
[Python]   File "C:\Users\PC\AppData\Local\NA-MIC\Slicer 5.2.2\lib\Slicer-5.2\qt-scripted-modules\DICOMLib\", line 790, in loadLoadables
[Python]     loadSuccess = plugin.load(loadable)
[Python]   File "C:/Users/PC/AppData/Local/NA-MIC/Slicer 5.2.2/NA-MIC/Extensions-31382/SlicerHeart/lib/Slicer-5.2/qt-scripted-modules/", line 558, in load
[Python]     loadedNode = self.loadGeUsMovie(loadable)
[Python]   File "C:/Users/PC/AppData/Local/NA-MIC/Slicer 5.2.2/NA-MIC/Extensions-31382/SlicerHeart/lib/Slicer-5.2/qt-scripted-modules/", line 791, in loadGeUsMovie
[Python]     if imageProxyVolumeNode:
[Python] UnboundLocalError: local variable 'imageProxyVolumeNode' referenced before assignment

Also, loaded volumes are seem wrong. Some of them looks like frames from the same video and the volume with multiple frames seems distorted too. My dicom files have “gems_ultrasound_moviegroup_001” private tags. I know there are topics about it but none of them solved my issue. I appreciate your help.

Finally, I want to mention that I split my DICOMDIR to the individual dicom files to open from the Slicer. Does Slicer supports DICOMDIR format or can it be the issue? Thank you in advance :slight_smile:

The safest is to delete any DICOMDIR file to make sure it is not taken into account when indexing the DICOM files. DICOMDIR file just provides a summary of files in the folder. We tried to used them in the past but they caused a lot of problems, because often files that the DICOMDIR file referred to were no longer there, or some files in the folder were not mentioned in the DICOMDIR file.

I’ll check what could have caused the UnboundLocalError exception that you saw.

1 Like

Thank you a lot. I want to ask one more thing, do files in the DICOMDIR contain the whole metadata? They have no extension and when I directly import them it doesn’t differentiate 2 different patients or studies. I only see volumes with single frames instead of videos. I know I asked too much but I would really appreciate any help. I saw so many people have problems with the gems_ultrasound_moviegroup_001 tag and it seems there is no direct solution :slightly_frowning_face:

By the way, I get different errors like this, I hope they may help:

 vtkITKArchetypeImageSeriesReader::ExecuteInformation: Cannot open ...  ITK exception info: error in unknown:  Could not create IO object for reading file .. [VTK]   Tried to create one of the following:
[VTK]     BMPImageIO
[VTK]     BioRadImageIO
[VTK]     DCMTKImageIO
[VTK]     GDCMImageIO
[VTK]     GiplImageIO
[VTK]     JPEGImageIO
[VTK]     LSMImageIO
[VTK]     MGHImageIO
[VTK]     MINCImageIO
[VTK]     MRCImageIO
[VTK]     MetaImageIO
[VTK]     NiftiImageIO
[VTK]     NrrdImageIO
[VTK]     PNGImageIO
[VTK]     ScancoImageIO
[VTK]     StimulateImageIO
[VTK]     TIFFImageIO
[VTK]     VTKImageIO
[VTK]     Bruker2dseqImageIO
[VTK]     GE4ImageIO
[VTK]     GE5ImageIO
[VTK]     HDF5ImageIO
[VTK]     JPEG2000ImageIO
[VTK]   You probably failed to set a file suffix, or
[VTK]     set the suffix to an unsupported type.
[VTK] Algorithm vtkITKArchetypeDiffusionTensorImageReaderFile(0000024A6FD70C30) returned failure for request: vtkInformation (0000024A704F1B70)

Edit: I want to clarify that problems with the gems_ultrasound_moviegroup_001 tag are not special to the Slicer app. I searched the whole internet, used dozens of viewers/code, and couldn’t read the content properly yet.

Hi, I wrote very similar code as the Slicer’s Heart extension in Python. I realized that one of my Dicom files have a missing header and got the same error. Therefore I deleted that file and the error is solved. Moreover, I realized that stored videos are in a cartesian system, and converting them to the polar coordinates solved my issue and managed to view them as in the machine. I need to validate that their views are correct but I hope I won’t need to spend more time in those nested tags :slightly_frowning_face: . Thank you for your previous answer again. I think this issue is solved.

1 Like