Volumetric mesh from CT file?

Hello,

I’ve recently discovered the 3D Slicer and it’s possibilities. I’m beginning to work on project for analysis of occlusal stress distribution in cantilever dental bridges. Our starting point is CT file of the jaws with teeth and from 3D slicer we need volumetric mesh which would be implemented in the FE software for the analysis.
I saw that 3D Slicer has extension (Segment Mesher) which could generate the required volumetric mesh. But, so far I’ve information that it works only with MR files? If this is right what are your suggestions for my future work?

Hello, Vasko.
I have not been using the Segment Mesher, but I expect that it should work perfectly with CT data. The reason is that the Segment Mesher will be applied to a Segment.
3D Slicer is capable of creating Segments from CT scan data, MRI scan data, PET scan data, and many other types of image data.

AFAIK, the Segment Mesher tutorial just happens to use MRI data to provide one example.

On the other hand, there may also be other (alternative) workflows that you can also consider, such as exporting the Segment (geometry) from 3D Slicer, and then meshing it in your own FE software?

—DIV

2 Likes

Hello DIV,

thank You for the reply. Can You tell me more about the alternative way You mentioned: “exporting the Segment (geometry) from 3D Slicer , and then meshing it in your own FE software”

What kind of data can I export in order to be able to create 3D FE model? Maybe You can point some tutorial where I can read more about it?

Hello, Vasko.
I think you can get some guidance from the online documentation. In particular the documentation about Segmentation mentions the core ability to export segments in STL and/or OBJ format.
You can find various segmentation tutorials for 3D Slicer online too.

As for the later step of importing it into FE software, others who’ve tried that workflow may have more detailed recommendations.

—DIV

Hi DIV,

can You tell me why the Segment Mesher is not appearing in the Segmentation drop menu? As You can see I’ve previously installed it through the Extension Manager, also I’ve restarted the 3d Slicer.

Thank You for he reply,
Vasko

Hello, Vasko.

A few points…

  • Consider updating to the latest version of 3D Slicer.

  • Ensure that you’ve restarted the application after installing that extension.

  • The drop-down menu you mentioned is not specifically a drop-down “Segmentation menu”, rather it is a drop-down Module menu, and it is possible that extensions might appear in some sub-menu there. [The only reason that “Segmentations” appears at the top of your list is that you must have clicked to use that particular Module most recently.]

  • Have you tried clicking the “Find module” search button [magnifying glass icon] immediately to the left of that drop-down Module menu?
    image

I have installed the extension, and can access it by following the above steps.

—DIV