Welcome dialog keeps reappearing

A brief intrusion in this thread.

The ‘Don’t show again and always OK’ checkbox does not work on Slicer at start and on exit, if no old configuration directory exists. At least on Linux.
You may test after

mv $HOME/.config/NA-MIC $HOME/.config/NA-MIC.bak

I mean, the dialog is shown everytime Slicer starts and exits, even if the checkbox is ticked. But it does not crash.

Could you check If the Slicer.ini configuration file already exists, does the “don’t show again” setting properly saved in it?

By default the Slicer.ini file should contain DontShowDisclaimerMessage=-1 and if you click don’t show checkbox and OK then it should change to DontShowDisclaimerMessage=1024.

DontShowDisclaimerMessage is always missing in Slicer.ini, when this file is created in an empty configuration directory.