Why does my XA type image appear as a series and not a single 2D image?

Hello All,

I’m trying to view an xray angiography, but i can only see/load it as a series of DICOMs that look like this:
What’s more is that these slices don’t appear as I would expect them to for an X-ray image, as I can’t see the surrounding ribs like I would in this DSA from the same patient:
I’m really confused as to why it says this series is of type XA when it seems more like a CT. Is there any way to combine the DICOM series into one xray? I would use the DSAs but unlike the DICOM series, they don’t contain the metadata for position and orientation.

Interestingly, very few users have ever asked for XA (either native or DSA) image support over the years, so we haven’t tested how well it works. There is a good chance that there are some trivial issues that we should fix. Can you share some example sequencea that you have problem with? Preferably images of phantoms or public data sets, but anonymized patient images are OK, too.

Hi Mr. Lasso,

thanks for the quick response. I’d like to share the anonymized patient data, but I’m not sure what is the best way to go about posting multiple .dcm files. How should I go about uploading them?

1 Like

You can upload to dropbox/onedrive/Google drive and post the link here.

Thank you, here’s the link:

Thank you. This series is created by a Siemens Axiom Artis robotic C-arm that can reconstruct cone-beam CT from rotational XA acquisitions. The series contains is a reconstructed 3D volume and a localizer image.

Presence of the localizer image messes up default loading, so for now you need to open “Advanced” section and chose the two loadables by imageType. One of them is the localizer image, the other one is the volume:

Loaded 3D volume:

I’ve implemented a mechanism in the DICOM module to detect such localizer images and load the volume correctly with default settings. It is currently under review and probably will be available in the Slicer Preview Release within a few days.

Mr. Lasso,

Thank you for the assistance, I didn’t realize these were rotational XA acquisitions.
I’m still not certain I understand how to reproduce the result you have. I follow the steps that you’ve put, 1. click Advanced, 2. click examine, 3. uncheck the 12: Sagittal (which I’m guessing is the localizer image), 4 and 5. click the the volumes, 6. load these volumes.
But when I load the volumes, it still shows up as a 2D object:

Trying to render this as a 3D volume crashes Slicer for me.

“12: SAGITTAL - imageType 1” is the single-slice localizer image and “12: SAGITTAL - imageType 2” is the 3D volume. Check only “12: SAGITTAL - imageType 2” and uncheck everything else, then click Load.

You may also try the latest Slicer Preview Release (revision 29227 or later), which should load the correct image by default (without enabling “Advanced”).