Why HeterogeneityCAD cannot produce the true number of % injected dose value and gray levels in a normalized PET image?

Dear professors,

I have a set of PET images with intensity value normalized to % injected dose. The intensity range of the segmented tumor is around 0.450275 to 1.482173. I applied the heterogeneityCAD module to extract different features. The gray levels turned out to be 3, the minimum intensity is 0, the maximum intensity is 2, median intensity 0 and range 2. It appeared that it can only give results in whole digit rather than in decimal values. In the original PET images the number of gray levels is up to 100. How can I get back the values in decimal places?

Thanks!
Mimi

Hi Mimi -

I’m not sure about HetrogeneityCAD, but you may also want to try SlicerRadiomics, as it is a newer project with updated methods.

Hope that helps,
Steve

Hi Mimi

The most probable reason is that you are providing the label map as your input in the field “Input Node:” instead of the PET volume node.

Jay

Hi Jay,

No. I put the normalized PET volume in input node. If it is the label map, then there are only 2 kind of intensities, 0 & 1.

Thanks!
Mimi

Can you upload the deidentified dataset to Dropbox and send me the link. I can have a look at the issue.

Thanks
Jay

Hi Jay,


Thanks!

Mimi

@MimiPoon thank you for sharing the dataset!

I confirmed SlicerRadiomics (and the underlying pyradiomics library) has a similar issue, as apparently we do not handle properly bin width that is less than 1.

I reported the issue here so you can track the progress: https://github.com/Radiomics/pyradiomics/issues/327

@MimiPoon I am sorry, I probably misled you by my earlier response.

First order features calculated by the Radiomics extension are represented by the floating point values. What I meant is that the values produced for the GLCM features are in integers only, and I am not sure if this is expected, or due to incorrect implementation of discretization.

After re-reading your post, I realized you were asking about first order features. Those appear to be correctly calculated with the Radiomics extension, see screenshot below for your sample dataset.

Please let us know if this resolves your question!

image

I traced down this problem, and updated the extension to fix it. If you use the Radiomics extension in the tomorrow’s nightly, or in the 4.8.1 tomorrow stable, you can get the updated version.

Currently the default bin size is set to 25, and the minimum bin size is limited to 0.01. Make sure you reduce the bin size in the settings, since otherwise you will not get meaningful values for your intensity range! If you think you need to use smaller bin size, let us know and we can update the extension to allow it.

Note that you can use the pyradiomics library directly to calculate the radiomics features from the command line, and configure feature extraction settings more flexibly.

Please let me know if there are any other issues related to the use of the Radiomics extension.

image

Dear Fedorov,

Thanks for your advice! Will try it tomorrow.

Mimi