3D viewer stops working after segmentation


I am trying to segment out different bone fragments from a CT scan of an ankle fracture. After creating the separate fragments (during which the 3D viewer worked the entire time) I attempted to export to .stl files. The .stl files do not open in the next software I need to use and the 3d viewer stopped working in slicer. I can only see 1/12 segments in 3d.

The eyeball is open for all of them, but I can only see my last segment.

Any thoughts?

We would need to know a bit more to be able to help with this:

  • How much physical memory do you have in your computer and how large is the image you are working on?
  • What Slicer version do you use?
  • Do you see any errors or warning in the application log?
  • Can you share any of the files or at least a few screenshots?
  • Does everything work well if you save the scene, restart Slicer, load the saved scene, and export the segments again?
  • Do you use “Export to files” feature?
  • Can another instance of Slicer load the saved STL files?
  • Have you tried exporting to OBJ format?
  • Which Segment Editor effects did you use? If you used “Grow from seed”, “Watershed”, or “Fill between slices”, have you clicked “Apply” when preview results were good?

I have 952 GB of memory on my laptop which is running Windows 10

I have Slicer 4.10.2

There are no errors or warnings popping up

I cannot share screenshots or images at this time

I did try to save, close, reopen and reload to no avail. the problem persists upon reopening. exporting did not improve either.

I used the export to files feature

I have not tried exporting to obj as this is not a supported file type for my next step.

I used threshold and scissors and were sure to click apply when necessary. the segments were all fine, but suddenly the 3d view just stopped working

Do you know how much memory (RAM) your computer has? Things may start to stop working if you run out of memory. You can configure more virtual memory (that uses disk space to make up for lack of physical memory) in Windows settings, but it’s better to confirm first that this is the problem.

Please also try with latest Slicer preview release.

Do you mean that segments do not appear after reopening? They do not appear in slice views either, or just do not appear in 3D views?

Please try obj file export as well and try loading the STL and OBJ files back to Slicer (this helps in determining if 3D mesh generation failed or it is just a display issue).

This would indicate a video card driver crash, but that should be fixed by restarting of the computer and Slicer. So, it is most likely there is something else.