error in show 3D function of segment editor module of slicer 4.8.1

I have Ct data of human tooth. I am trying to create stl file for gmesh.I have constructed nrrd using a stack of 300 tomography slices using Fiji. The nrrd file is 9.2MB. I could segment the data but show 3D doesn’t work with Slicer 4.8.1 although it shows 3D for sample data downloaded for slicer.
Pls help.
Anis Fatima

What do you do? What do you expect to happen? What happens instead?

Have you clicked the small box button in the top-left corner of 3D view to make sure it is in the field of view?
Does it work with latest nightly Slicer version?

I am trying to create a 3D after segmenting the data but there is no image seen when I click show 3D. Yes I tried to center the 3D view on the screen but it didn’t work.
I could get 3D when I work with sample data files like CT-chest. nrrd , MR-head.nrrd. But the image is not observed with my CT data.

I have not tried nightly Slicer version.

Anis Fatima

I have now tried nightly Slicer 4.9 with the data I had problems. 3D surface is not seen again.Also I have tried the other CT data set but could not get 3D in the window.

Could you please load your data, draw some segments on it, click Show 3D, upload the application log (menu: Help / Report a bug) to dropbox/onedrive/gdrive, and post the link here?

Could you take a screen capture of what you are doing, upload to dropbox/onedrive/gdrie and post the link here? (you can record screen capture using free sceencast-o-matic tool)

I cannot install dropbox here.
I tried gray scale modelling of my 9.2 MB stack and could see 3D. I changed the background colour to black and after zooming I got the 3D.

Now the problem is with full data set uploading. I have nrrd file of 624 MB. After segmentation 3D surface processing takes too long and software shows Not Responding.

Is there any setting for increasing the memory for processing large data?

Is it must to use nrrd file format. When I load tiff from the folder only the selected tiff is displayed in the axial view window. When I scroll to see other files of folder I could not see all files of the folder.


Set smoothing factor to 0.0 (click the small down-arrow of the “Show 3D” button to edit smoothing factor) or temporarily turn off 3D display while editing the segmentation. This requires recent nightly version of Slicer, which has several more optimizations, which drastically improves segmentation 3D update speed compared to 4.8.1.

NRRD format is not required but it is a good file format for storing 3D image data. Consumer file formats, such as jpg, png, and tiff are not well suited for medical image storage, due to low bit depth (typically up to 8 bits), lack of metadata (slice spacing, image orientation, etc.), and fragile frame management (difficult to detect missing or incorrectly ordered frames).

You need to disable “single” option. See this page for details: Documentation/Nightly/FAQ - Slicer Wiki