Build failure on Ubuntu

Just did and update and tried to rebuild Slicer. I get the error:

loading initial cache file /home/lorensen/ProjectsGIT/Slicer-Superbuild/zlib-prefix/tmp/zlib-cache-Release.cmake
CMake Error at CMakeLists.txt:3 (PROJECT):

Unix Makefiles

does not support toolset specification, but toolset


was specified.

– Configuring incomplete, errors occurred!
See also “/home/lorensen/ProjectsGIT/Slicer-Superbuild/zlib-build/CMakeFiles/CMakeOutput.log”.

I did a fresh build on ubuntu with make -j20 and got an error that had scrolled off. When I did a second build it completed with no error. I’ll try another fresh build into a log file and see if it’s the same issue you reported.

Clean build, same error.

got bisect says it was this commit that broke the build:
[7cafe8c8bc9be7128ffd3179a734a98850539af9] ENH: Update ExternalProjectDependency based on commontk/Artichoke@5ee3d50

@jcfr looks like your commit:

commit 7cafe8c8bc9be7128ffd3179a734a98850539af9
Author: jcfr jcfr@3bd1e089-480b-0410-8dfb-8563597acbee
Date: Fri Apr 14 22:24:36 2017 +0000

ENH: Update ExternalProjectDependency based on commontk/Artichoke@5ee3d50

This commit improves the support for Ninja generator by ensuring the
option USES_TERMINAL_* options are set to give Ninja access to the
terminal when the CMake version supports it.


Also Update CTK to integrate a similar update:

$ git shortlog 19fc678..b8587e5 --no-merges
Jean-Christophe Fillion-Robin (2):
      Update ExternalProjectDependency based on commontk/Artichoke@5ee3d50
      ENH: ExternalProjecDependency: Re-apply commontk/CTK@6cc426b

git-svn-id: 3bd1e089-480b-0410-8df

Interesting, I’m using cmake version 3.3.2 and the test to use the new USES_TERMINAL_* says:
# USES_TERMINAL_* options were introduced in CMake 3.4

Looks like the test is wrong.

Another clean build completed without error. Probably a race condition.

IMy cmake is 3.5.1 so I didn’t see the TERMINAL issue.

In Slicer/CMake/ExternalProjectDependency.cmake

Test should be:

The same error exists in CTK. I will update my cmake, but I think this error should be fixed.


Thanks for the note. I will update the CMake modules now.

As soon CI returns green, I will update CTK and Slicer.

Change integrated in Slicer in r25978