Color problems accessing Slicer3D on an Ubuntu install

Problem report for Slicer 4.8.0 linux-amd64: [please describe expected and actual behavior]

image

the image shows the colors are completely off. I am using Slicer3D through a VNC connection. Slicer3D is hosted on a Ubuntu machine.

Did older versions of Slicer work ok? The gradients look kind of like compression artifact if VNC downgrades the quality due to insufficient bandwidth. Others might have suggestions, but this is may not be a Slicer problem per se.

Other people have used VNC successfully – see thread below. I’ve also used TeamViewer a few times and had good results, although usually with a Windows system hosting Slicer.

Looks like color quantization artifact to me, too. These instructions may help for setting up VNC appropriately: https://askubuntu.com/questions/281177/colours-background-messed-up-in-vnc-viewer

1 Like

I will try an older version. No VNC compression used as I configured it for maximum quality.

Thanks.

I don’t think it is a quantization problem. The problem happens inside Slicer. Other than that the desktop looks totally fine. And inside Slicer it seems like the lookup tables are all wrong. Also I had already configured VNC for maximum quality… check this side to side between chrome and slicer. The background in Slicer looks off and as shown in my previous post the DICOM volume looks off too.

image

It seems that only the OpenGL windows colors are off. Can you check other applications with OpenGL windows? Can you try with other VNC clients/servers and other remote desktop software (TeamViewer, etc)?

Update:

TeamViewer did not install (problem with AWS).

Tried with Slicer 4.4 and had the same problem

Tried with Slicer 4.0 and it did not start because a Qt dependency.

Try something that is pure OpenGL (no VTK) like MeshLab. It is small and should be in the package repository already.