Cranial Bone flap Thickness Measurement

Operating system: Windows 8 version 6.3
Slicer version: 4.10.2
Expected behavior: Generating a centerline and analyzing segment thickness
Actual behavior: None

Hello, I am a new Slicer user struggling with an old, debated problem.
I generated a segmentation, defining the craniotomy bone flap in patients who underwent neurosurgical procedures, using T1 weighted MRI images.
I saved the segmentation, using both .seg.nrrd and .stl extensions. Then I tried to follow the “How to analyze the thickness of the model” tutorial, but I am stuck. I tried loading the .seg.nrrd segmentation together with the T1 volume. After that, as suggested, I searched the Simple Filters module and used the BinaryThinningImageFilter, using the T1 volume as input volume and creating a new volume as output. However, after clicking the apply button I waited 40 minutes, but the progress line still remained at 0%. I thought the problem was the extension of the file, so I used the same segmentation generating a .stl file. Then I repeated the same process, ending with similar results.
Theoretically speaking, analyzing the bone flap thickness should easily to compute. However, I am struggling with it, how do you suggest proceeding?

Kind regards

You need to apply the filter not to the T1 volume but to the segmentation (exported to a labelmap). Make sure to crop the segmentation to the minimum necessary size (e.g., using Scissors tool). After this, computation should take a few seconds.

Dear Andreas,

Thank you for your reply. I tried to implement your suggestion, and it worked partially.
At the moment, I am worried I did something wrong in the first passages, which is flawing my result. So, I will try to explain what I did and maybe you can help me fix it.
I loaded a T1 volumetric image in Slicer, then used the Segment Editor to paint out the bone flap. Afterward, I smoothed the created ROI and saved it through the save button using both the .seg.nrrd and .stl extensions. I think this is the passage that is generating my problems. Although I created an ROI it seems to rely on the native volume for dimensions, volumes, etc.

So, as you suggested I cropped the native volume around the ROI, then I created a lablemap and applied the passages in the “How to analyze the thickness of the model” tutorial. Although the process functioned, my results were not similar to the ones in the tutorial and I did not have the green and red outline of my ROI.

Maybe I am struggling with really complex tasks for a beginner user, but I really hope you can help me.

Many thanks in advance,

Can you share your seg.nrrd file (upload somewhere and post the link here)?

Sure, could you suggest me somewhere to upload the file?

Also, I created the ROI segmenting a Nifti T1 volumetric image. Is it correct that NIfti images do not store any patient’s information?

Anything works - Dropbox, OneDrive, Google drive…

Nifti does not store patient health information. In theory, somebody could inject some patient information into some fields, so if you want then you can open the file in a text editor and have a look at the first few hundred bytes of the file to check if you see anything about the patient there, but it is highly unlikely.

Dear Andreas,

Sorry for the late reply. Underneath you can find the segmentation link:

Thank you for helping me,


Dear Andreas,

I think I came closer to the result. After cropping the image, applying the Bunary thinning and Danielsson mapping distance filters this is the result. However, to me, it seems that Slicer is sampling the whole volume rather than the segment. How can I try to fix this problem? Did you manage to look at the file I sent you earlier?

All the best,

Dear Andras,

I tried the Skeleton module, and I was able to define the segmentation’s center-line. Therefore, I am wondering what I did wrong. Did you manage to look at the segmentation I send you a week ago?

All the best,