Diffusion brain masking

Operating system: MacOS Mojave 10.14
Slicer version: 4.10.2
MR: Philips

I wanna create a diffusion brain mask but I have the following problem:

"Diffusion Brain Masking standard error:

ERROR: In /Volumes/Dashboards/Stable/Slicer-4102-build/VTK/Common/ExecutionModel/vtkDemandDrivenPipeline.cxx, line 709
vtkCompositeDataPipeline (0x7f886719a800): Input port 0 of algorithm vtkImageWeightedSum(0x7f8867199d20) has 0 connections but is not optional.

/Applications/Slicer.app/Contents/Extensions-28257/SlicerDMRI/lib/Slicer-4.10/cli-modules/DiffusionWeightedVolumeMasking: Error parsing Diffusion information, no B0 images"

I have DWI images in DICOM. In the converter (diffusion - import and export - diffusion weighted DICOM import (DWI convert) transformed the images into “nrrd”.

I can not change the “DWI Component” parameter (module Volumes, field Scalar Display). Besides the value of “DWI Component” is 0. How can I make 10?

Thank you so much!

Hi this sounds like it is not actually DWI data. Please check your original DICOM data and acquisition. It may be a trace image with one component instead of the required components (usually 20 or more) needed for diffusion tensor analyses.

I’m sure that:
my format data is dicom classic;
my data represents DWI data;
data was been acquired considering 2 b-values and 15 gradient directions.
Besides I have exported my file from workstation!

I send you dicom data and the screenshots of my file!

22 00 34


In that case please use Slicer 4.10 and make sure you load data with either the DWIConvert or DCM2nii module. Then look in the Volumes module of Slicer and check that you can see all the expected components (b0 and gradient images). Then please send an explanation of exactly what steps you took, including module names, and the result.

My 3dslicer version is 4.10.2. I send you my steps now.

Are you able to share the nrrd data via Dropbox or similar? The error means it is not finding any baseline (b-value near 0) images in the dataset. Every DWI acquisition should have one or more of these.

The issue is that the DICOM files cannot be successfully converted to NRRD.

The NRRD file you uploaded has only two diffusion weighted images (both are b=0). I also tried by myself using both DWIConvert and Dcm2niix (a new module that was recently added in SlicerDMRI to convert DICOM). They gave the similar output, that only two DW images can be identified.

Looking into the log file from Dcm2niix, it says “Error: Conversion aborted due to corrupt file: /Users/fan/Desktop/Diffusionpugliese/FILEDICOM/XX_0050”

I am not entirely sure why this happened, but it seems there is something unusual in the input data, if you could try to export it again, or try on data from a different subject.



Hi all,
I too am getting an issue with the Brain Masking with an error stating there is no b0.

C:/Users/18166/AppData/Roaming/NA-MIC/Extensions-28257/SlicerDMRI/lib/Slicer-4.10/cli-modules/DiffusionWeightedVolumeMasking.exe: Error parsing Diffusion information, no B0 images

The files I have contain 34 directions. There is a multivolume and a DTI volume file as well. None of which are behaving. This is my first attempt with unique de-identified information. Any advice would be welcome.

Hello, I keep getting this error. I’m trying different dwi files but I get the same error every time. Is there a complete solution for this error? Can you suggest me a sample file where this error is not received?