Downloading extensions for older releases

Due to the recent transition to the updated Extension Manager and Data Store infrastructure, when using Slicer-4.11 (or older) version, users will need to manually download and install extensions from the new extension server, and download data sets from an alternative server instead of using the Data Store module. Rationale for the transition can be found here. We anticipate that this will be a temporary measure will the transition is finalized.

Thank you for your patience! Please do not hesitate to reach out here on Discourse if you have questions or need assistance with extension installation.

– Slicer Dev Team

Download and install extensions

  1. Go to the Slicer Packages server
  2. Select your release version
  3. Find the extension of interest in that releases extensions folder
  4. Click the download icon to download the extension package
  5. Follow the instructions for manually installing the extension
  6. The extension may have dependencies. Check the corresponding .s4ext file in the extension index to see what other extensions may need to be installed.

Download data sets that were previously hosted on the DataStore

If you are looking for data previously accessible via the Data Store module (hosted on the DataStore server), it can be found here.

1 Like

Does this work only for the already released “Stable” versions and any Slicer “Preview” releases prior to the transition to the updated Extension Manager infrastructure? Date?

I downloaded Slicer 2021-08-24 revision 30133 from the Applications/packages/Slicer/draft/30133 directory and then download the SlicerDebuggingTools extension in the Applications/packages/Slicer/draft/30133/extensions directory. I then installed Slicer and then followed the instructions to manually install the extension. Upon doing so I get the same results as I posted about at Unable to manually install extension to manual Slicer build.

Yes, these instructions are intended for the older Releases / Previews that use the old extension manager infrastructure. The bug you encountered affects the new versions, and will be fixed.

To give some context, this post was created as a landing page for anyone attempting to reach the old extension manager site. It has been made public at this time because the old server is to be shut off today.

I am a little bit confused with this message. Does this mean that current stable will no longer receive updates from new extension server. Or once the new extension infrastructure is in place, everything will be the same as before (for stable and older versions)?

If this is indeed temporary, I would suggest adding the temporary to the section below.

We still build and upload releases for the Slicer-4.11, but that cannot download it from the new extension server and you need to download and install the packages manually. Slicer-4.13 and above can download and install extensions from the Extensions manager as usual.

Yes, it is temporary. We’ll create a new stable release within 1-2 weeks and then both the latest stable (Slicer-4.14) and latest preview (Slicer-4.15) will be use the Extensions manager as usual.

Updates

Download and install extensions

Older release of Slicer can now browse and install extensions directly from the application.

For more details, read about the Slicer legacy extensions catalog at KitwareMedical/slicer-extensions-legacy-webapp

Does this mean that current stable will no longer receive updates from new extension server.

To clarify, updated extension associated with the current stable release are uploaded and available to the user.

@jcfr

I just tried this with the stable on windows and while I can indeed install the extensions, it throws this error


"Downloading extension [ itemId: 60ae2680ae4540bf6a89dc81]"

"Error retrieving extension metadata: amd64, win, MONAILabel, 29738 ({2d46a981-d88e-45d3-bbc0-004d69568701}: 401: Error transferring http://slicer.kitware.com/midas3/api/json?arch=amd64&os=win&productname=MONAILabel&slicer_revision=29738&method=midas.slicerpackages.extension.list - server replied: INTERNAL SERVER ERROR)"

"Installed extension IntensitySegmenter (60ae2680ae4540bf6a89dc81) revision ace1890"

But more concerning is the update extension behavior. When I click on update button, it showed updates for all installed extensions (which is not true, but I suppose it is an artifact of architecture change), and when I tried to update SlicerMorph, it actually disabled the extension (after the restart) with the error that the installed version is not compatible. The only solution I found was to uninstall and reinstall it. SlicerMorph was the only extension that the update partially work. For everything else I am getting this:


"update check for SurfaceWrapSolidify complete: 'f70c039' available, 'a9512a0' installed"

Uncaught SyntaxError: missing ) after argument list

"Retrieving extension metadata [ extensionId: 613b6f1d342a877cb3bf031f]"

"Downloading extension [ itemId: 613b6f1d342a877cb3bf031f]"

Thanks for reporting the issue.

As you noticed, the Slicer legacy extensions catalog still have some rough edges and we plan on addressing these.

Updates

Thanks for the report.

This particular issue has been fixed in KitwareMedical/slicer-extensions-legacy-webapp@90ad5a22b and corresponding change have just been deployed.

Background: MONAILabel is not available in the latest stable release and the api call should not fail.

Thanks JC. What worried me is not the MonaiLabel, but the error I got when I tried to update WarpSolidfy extension. Glad to hear that it will be fixed.

Updates

This particular issue has been fixed in Fix extensions manager integration by jcfr · Pull Request #5846 · Slicer/Slicer · GitHub and corresponding changes have been integrated.