Error in Cropping DTI Volume

(erdi kara) #1

Operating system: Linux 5.0.13-1, Opensuse
Slicer version: 4.11
Hi all
I am trying to crop a DTI volume with Crop Volume module, it is a *.nhdr file.
Here is the screenshot:

but when I hit “apply”, it does nothing. In fact, a cropped volume appears in “Data” section but slicer says it is invalid.


Am I missing some theoretical info like " you cant crop a DTI volume" ? Thanks for the help!

(Andras Lasso) #2

You can find the error message in the application log (red X icon in the lower-right corner): “CropVolume: Diffusion tensor volumes are not supported by this module”.

It would not be too hard to add DTI support to this module, but for now you need to do a workaround: crop a scalar or DWI volume using “Crop volume” module then use that as “Reference volume” in “Resample DTI volume” module.

(erdi kara) #3

Thanks for the prompt response @lassoan. However I dont have DWI volume for this data set. As far as I know, mathematically we cant go DTI–>DWI. I used this module for dwi images but I dont know how to proceed in this case. Can you refer to any answer or tutorial by any chance? Thanks for your time again.

(Andras Lasso) #4

You can generate a reference volume from any volume e.g., download MRHead example, go to Crop volume module, choose MRHead as Input volume, enable interpolated cropping, enable isotropic spacing, optionally change the spacing scale, set the ROI, then click Apply. Then use the generated cropped volume as reference volume in “Resample DTI volume” module.

(erdi kara) #5

I think I did it. Thanks for letting me know about that module @lassoan Especially tensor correction section has been so helpful in our research.

1 Like