Fixing extension testing failures

there are a number of tests in the SlicerDMRI extension build that I would like to fix:

Some of them (e.g. py_TractographyExportPLY, py_TractographyDownsample) report a short message saying

[/Users/svc-dashboard/D/S/A/Slicer-build/bin/] exit abnormally - Report the problem.

I’ve found these potentially related threads, and have read the information in the corresponding links:
PythonSlicer problem with vtk and ReadData · Issue #6484 · Slicer/Slicer · GitHub
Extension tests fail on CDash, why? - #13 by RafaelPalomar

However, it is unclear what the appopriate sorting for the imports is: is this documented somewhere? Otherwise, what is the recipe? I have tried a few different sortings without success for e.g.:

Also, there are a number of tests (e.g. py_fiber_visibility_crash2438) that fail because data nodes are not available in the scene, e.g.

 tractNode = slicer.util.getNode('tract1')
 slicer.util.MRMLNodeNotFoundException: could not find nodes in the scene by name or id 'tract1'

I’ve seen that the data does not get loaded into the scene (it does if I use a ModelFile type, but then fails to get other fiber data type-specific properties):

The command looks correct, though. What am I missing here? How can this be tested properly/fixed?

Note that the data was moved (related topic Actual data content of and the correct uris for the data would be


Are you able to replicate the test crashes in a local debug build?

Regarding the import order difference maybe you can join one the Tuesday morning developer meeting and we can discuss. It should just be a matter of following the class hierarchy and library dependencies.

Thanks for answering Steve.

Have not tried debugging; I am able to reproduce the issue from a command line run. Have read the debugging instructions in the Slicer documentation, but it is unclear to me how this can be debugged (this being an extension, this being a Python module, etc.).

Have a meeting 11:00-12:00 ET. If it does not conflict, I may join.