How do I view a Spatial Registration Obj in slicer?

I have installed a few of the extensions, but it still will not load the SRO dcm file.

You need SlicerRT. If that’s still not working provide more details.

Hi Steve. I had installed SlicerRT extension, but slicer just said ‘Failed to load’ when I tried to add an SRO file that I had gotten from a vendor.

See if you can get de-identified sample data that you can share so other people can test and make suggestions.

Hello Steve. Is it possible that SlicerRT needs more than just an SRO to display anything? I am not sure if it would display the attributes, or if it also expects to have images loaded prior to have something to apply the SRO to? If it should work with just the SRO, then I should be able to get an anonymized file.

If you load the SRO successfully then you should be able to inspect it and even display it in the Transforms module, but generally yes, you need some data to make sense of it.

Ok thanks. But it just errors with no meaninful details as to why. I have attached here the SRO file that will not load into Slicer. It does load into a couple other DICOM attr viewers just fine. So if you can determine if the issue is with the SRO or SlicerRT, that would be great. Thanks in advance.

Mike

(Attachment cosylab_sro_fixed_tags.dcm is missing)

@MikeC You probably need to share via a different method (dropbox, google drive, etc).

@lassoan @cpinter @gcsharp do you have input on this?

Attaching the file again, w/o the dcm extension this time .

(Attachment cosylab_sro_fixed_tags is missing)

Mike, did you attach to the discourse? I don’t see any attachment.

Maybe you can e-mail it to me or create a public download link.

I had attached it via email notification, but also just tried to upload it here and that didn’t work either. So I would be happy to email it to you if I can get an address. Mine is mikecourtney48@yahoo.com if you would rather reach out to me directly rather than post it here. Thanks.

File received. Thanks! Don’t hesitate to ping me if I am silent too long.

Hi Mike. I don’t yet have a final answer, but this REG has an uncommon format. Does Cosylab (the manufacturer) provide a DICOM conformance statement? -Greg

Hello Greg,

I can reach out to Cosy for a statement. I just searched their web site and didn’t find one there that’s publicly assessible.
But maybe this will be enough for now. Here are the tags that are parsed by another viewer, and here is the log file detailing the parsing is attached. A quick look at the tags by myself doesn’t show anything out of expectations, but maybe I missed something.

Thanks,
Mike

(Attachment CosyLabSROLogFile.txt is missing)

DICOM conformance statements must be made publicly accessible. If the company does not make one available, then it means that they actually do not officially support DICOM in their products. DICOM import/export may be just some untested, experimental feature.

Hi Mike,
I fully agree with Andras. Cosylab needs to publish a conformance statement. Until that happens we can only guess.
In my experience w awful vendor REG objects, there are two major misunderstanding. The first is frame of reference issues. The second is IEC vs DICOM.
We are happy to help, but vendor support is needed.
Greg

Hi guys,

I will try to get their DCS, although it may not be a released feature yet. More soon.

Thanks,
Mike

Meanwhile, what you can do is grab the Transformation Matrix out of the REG and stuff it into an ITK transform file. The format is below:

#Insight Transform File V1.0
#Transform 0
Transform: AffineTransform_double_3_3
Parameters: 1 0 0 0 1 0 0 0 1 30 20 10
FixedParameters: 0 0 0

Note the rotation goes first, followed by the translation. You might need to transpose (invert) the rotation, and/or negate (invert) the translation.

Problem solved. They had a formatting error in their xform matrix. It imports now. Thanks for the replies.

1 Like