How to make a translucent model suitable for scientific publication


How to make a translucent model which I will then be able to export as a semi-transparent model.
And I know the “opacity” option but after exporting the stl model this model is still opacity. I want semi-transparent model.
Example figure with random article. I would like to do similar effect.

We usually just set the view background color to white for publications.

But if you want to capture a screenshot with transparent background then you can do that by copy-pasting this script into the Python console.

Thanks for the answer
I understand that I cannot export a transparent model. Directly in 3D slicer,I need to take a screenshot “3d view” with translucent model skull with brain cast and then change the background in Photoshop, etc or maybe is there a suitable tool for making a white background directly in 3D slicer?
How option “opacity” is better in “Segmentations” or “Models”.

You can actually export a transparent model, directly in Slicer, using the script that I linked above. You can copy that image over content in Word, PowerPoint, etc. and the background will be visible wherever the view content is transparent.

You can also set the view background to white if you know that you’ll show the content over white background and then you don’t need to copy-paste a script.

There is no difference, they are both equally good for making a 3D object semi-transparent.

1 Like

Thank you for your answer.Your answer is very helpful:)

I see that also turning off the “3D cube” and “3D axis label” options will allow me to get an effect like in the attached image.


Also, explore the Lights module in Sandbox extension for better control over shadows.

1 Like

Thank you for answer.
I understand that the only option to take a screenshot is the “3D View” is the "Annotation Screenshot option?
Is there a 3d view rendering option?

You can use that (and simply switch to 3D layout option for 3D rendering only screenshot). Or you can follow the contents of this thread to create a high-resolution capture via little bit of python scripting:

1 Like

Thank you
I have one more question.
I made a model in 3D slicer with a semi-transparent human body model and non-transparent bone model.
I have a problem because there is a strange overlap between the human body model (white model) and the bone model (red).
Can this be fixed?

This looks like “z fighting” - almost equal surface mesh elements are rendered on top of each other.

Do you still display the original segmentation and the exported model? Hiding the segmentation or the model will fix the issue then.

Have you enabled “depth peeling” in the 3D view controller? That option is required for correct rendering of transparent surfaces.

Thanks for help.
Yes, “depth peeling” function is enabled.

I first exported “the human body” segmentation as a model then bone (red) segmentation exported as a model and I see that there is no longer a problem. First I did white model then a red model.

To me this looks like you have a “negative” of the vertebra as part of the body model. One option is to segment the body first (with threshold say), close any connections to the outside air and remove islands to get a homogeneous block. Then add the vertebra segment.

1 Like