Loading Philips 3D US

I tried to load this file but it seems to be distorted. I can’t save in the cartesian dicom with the Philips software. There’s a way to correct it?

I didn’t got a response. There’s some way to fix this image?

The DICOM file is formally Ultrasound Multi-frame Image Storage , but in fact some private Philips format with tons of private tags. Seems to be Native 3D Cartesian (see 0x200d,0x2005). I think i could guess spacing from private tags, looks like

Here is MHA file (is not compressed, so bigger as original compressed DICOM image) and i set origin and orientation to default (you might examine private tags)

1 Like

The file loads correctly for me with Slicer Stable Release, if SlicerHeart extension is installed:

  • Go to DICOM module
  • Drag-and-drop the file to the application window (this imports the file immediately into the DICOM database)
  • Double-click on the patient (or study or series) to load the image

i have drag-and-dropped, spacing was wrong

may be not found that extension, thanks

Thanks a lot for checking this @issakomi. Yes, the default Scalar volume reader plugin cannot get the spacing correctly. You need to install SlicerHeart extension, as it has a plugin that can properly load Philips Epiq/Affinity 3D ultrasound images:


Yes, works, the same spacing. Thanks.

1 Like

It works for me too but seems distorted when compared to original image

Look the difference between the printed and original picture


@Rodrigo_Visconti What spacing values do you see in Volumes module’s Volume information section? You can load the image incorrectly if SlicerHeart is not installed or you don’t use DICOM module to import and load the image.

You can take an image with objects of known sizes and measure them in Slicer to verify that there is no distortion.

1 Like

Thanks for the tips. I think it worked well this way

1 Like

2 posts were split to a new topic: How to load Siemens 3D ultrasound data