Master with Qt5 build fails

Cloned Slicer master (b748b88cefa57bc126f3a5c64a4fb59c28e4bb9b) and tried to build with Qt 5.9.1.

Received many generation errors similar to:

  CMake Error at Libs/vtkAddon/CMakeLists.txt:94 (add_library):
    Cannot find source file:

      C:/d/Slcr/S4D/Slicer-build/Libs/vtkAddon/vtkAddonHierarchy.stamp.txt

    Tried extensions .c .C .c++ .cc .cpp .cxx .m .M .mm .h .hh .h++ .hm .hpp
    .hxx .in .txx

Has anyone else experienced this?

Edit: not suprising, but build errors follow on the form:

CUSTOMBUILD : CMake error : CMake can not determine linker language for target: vtkAddon [C:\d\Slcr\S4D\Slicer.vcxproj]

Most likely related to the VTKv9 update.

I submitted issue 17217 to upstream VTK project and proposed a fix in MR vtk/vtk#3794 (already added to Slicer fork of VTK).

This addressed issues I experienced on Linux.

Look like there are still some issues.

Here are some related references that will be helpful to debug:

It turns out that the hierarchy stamp file has been removed in latest VTK:

This means the following Slicer file would have to be updated accordingly:

Thanks for the patch @adamrankin

For future reference:

It has been integrated in r26834

2 Likes