Modules installed from extensions do not show up during search

Operating system: Windows 10
Slicer version: Slicer 5.3.0 and 5.2.1
Expected behavior: Installed extension should show up when I search for modules after Slicer restart
Actual behavior: I cannot use online extension installer due to corporate network. So when using the offline installer, the restart button stays grayed-out. When I manually restart, the extension manager says the modules are installed, but when I search for them, they do not show up. I have tried this on both the stable release and the preview release, with no success. I know some modules wont show up during search, but the ones I am using (IGT modules), do specifically show up.

Any help would be highly appreciated!

What you describe indicates that the extension package you were trying to install did not match your Slicer version. If you open the Extensions Catalog website from the the Extensions Manager in Slicer then it will show the extension packages that match your Slicer version:

Yes, your extension zip file has a revision number such as 31317 which means it was built specifically for Slicer 5.2.1. Other versions can’t be installed because there could be compatibility issues.

@lassoan @jamesobutler Thank you for your replies. I did open the catalog website from the extension manager. I installed the SlicerIGT, SlicerIGSIO which are built for 5.2.1. They are still not showing up in the module menu. I also double checked if the extensions were built for 5.2.1 here (SPKC).

Just for curiosity, the other extensions I have installed are modelcropper, easy clip, SlicerJupyter and SlicerOpenIGTLink. None of them show up in the menu after installation.

Is your Slicer installation folder writable?

Yes. I actually ended up getting admin access to the system and installed Slicer as an admin. Allowed Slicer access through the Firewall as well.

It still refuses to download extension directly from the extension manager (error: Failed downloading:

And installing from file still doesnt show the module in Slicer.

Edit: Python console had the following:

[Qt] Could not get the INetworkConnection instance for the adapter GUID.

[Qt] Could not get the INetworkConnection instance for the adapter GUID.

[Qt] Failed downloading:

It seems that network access restrictions on your system are so strict that it becomes very difficult to access the internet. This list error indicates that the application does not even authorized to query the list of network interfaces. Try launching Slicer as an administrator. If you use some third-party security or firewall, try to add Slicer.exe and SlicerApp-real.exe to the whitelisted applications.

If none of these help then the easiest could be to download and install Slicer at your home computer, install all the extensions that you need, and then copy the entire Slicer installation to a USB stick. Since recent Slicer versions are fully portable, you can run it on any computer directly from the USB stick; or you can copy the entire Slicer folder to the restricted computer and run it there.

There are also some overly aggressive antivirus systems that remove DLL and exe files after they are installed. That may be another reason why they don’t show up when you install them from a downloaded extension package. You can have a look in the NAMIC subfolder in your Slicer installation folder to see if there are any DLL or exe files after you install an extension. If there aren’t then you can try to add an exception for Slicer to allow installation of additional executables.

If the distrust in third-party applications is so strong in your organization then they may consider letting you installing applications on your computer in a virtual machine.

It was this. Antivirus was the issue. Adding exception for Slicer.exe solved the problem. Now I can install from file and work with the extensions. The internet installation is still not solved (I dont think it will be unless there is a company-wide change in policy).

Thank you for all the help!

1 Like

Thanks for the update. Which antivirus software caused this trouble? In the past some users had this problem with Avast.

They actually use Windows Defender. I had to contact IT support to add the extension. So I do not know more details about how they dealt with the exception.

1 Like