Problem with DICOM import


I already read questions about this problem, but for me nothing worked.
I used to use 3D slicer with DICOM files without problem. After 2 or 3 months without using it, yesterday I tried and it doesn’t work (for the same DICOM files…).

I updated the Slicer version (it is now 4.10.2) and I am working with LINUX (CentOS Linux 7).

I try to import DICOM series and I receive the same error I saw for lots of people:
“Slicer has caught an internal error.
You may be able to continue from this point, but results are undefined.
Suggested action is to save your work and restart.
If you have a repeatable sequence of steps that causes this message, please report the issue following instructions available at
The message detail is:
Exception thrown in event: Calling methods on uninitialized ctkDICOMItem”

  • I changed directory (with a shorter one) and same error;
  • I used DICOM patcher and another error:
    " DICOM patching started…
    Unexpected error: ‘module’ object has no attribute ‘UID’"

I am using original clinical DICOM files, I didn’t change anything, it works with other softwares and I already opened them with Slicer before without problems…

Can someone help me please?

Thank you in advance!!

Try to create a new empty folder in writeable location, choose that as DICOM database folder, and re-import your DICOM files. If you still have issues, follow suggestions on the DICOM FAQ page:

Hmm, that’s odd - maybe try the ideas in DICOM FAQ? How about deleting the settings?

Thank you.

I did what you said (@lassoan ) and now I don’t see the error message anymore. BUT when I try to import DICOM data…

“Directory import completed.
0 New Patients
0 New Studies
0 New Series
0 New Instances”

I already delete the .*ini files as in “deleting the settings” (@pieper) and the same thing happens…

Any more ideas how to fix this??
Thank you again!

I just saw that as soon as I open Slicer, although the interface appears “normally”, at command line I have the message
“Switch to module: “Welcome”
There was an error during execution of the statement: " CREATE TABLE ‘SchemaInfo’ ( ‘Version’ VARCHAR(1024) NOT NULL );”
Error message: “disk I/O error Unable to fetch row”
Could this be the reason? What does it mean and what can I do to fix it?

Thank you!!

There’s something wrong with your dicom database file. Perhaps you don’t have permissions (you are using linux. so maybe you ran as root when the database was created - just guessing here). In any case maybe try creating a new user account to start fresh.

1 Like