Problems with DICOM import


I already read questions about this problem, but for me nothing worked.
I used to use 3D slicer with DICOM files without problem. After 2 or 3 months without using it, yesterday I tried and it doesn’t work (for the same DICOM files…).

I updated the Slicer version (it is now 4.10.2) and I am working with LINUX (CentOS Linux 7).

I try to import DICOM series and I receive the same error I saw for lots of people:
“Slicer has caught an internal error.
You may be able to continue from this point, but results are undefined.
Suggested action is to save your work and restart.
If you have a repeatable sequence of steps that causes this message, please report the issue following instructions available at
The message detail is:
Exception thrown in event: Calling methods on uninitialized ctkDICOMItem”

  • I changed directory (with a shorter one) and same error;
  • I used DICOM patcher and another error:
    " DICOM patching started…
    Unexpected error: ‘module’ object has no attribute ‘UID’"

I am using original clinical DICOM files, I didn’t change anything, it works with other softwares and I already opened them with Slicer before without problems…

Can someone help me please?

Thank you in advance!!

A post was merged into an existing topic: Problem with DICOM import