Samsung SonoAce 4D ultrasound mvl file loading

Hi,
Thank you for accepting me!
I am new here, I am trying to import dicom files from a Samsung sonoace machine, but I am getting error!
Thank you!

3dslicer error

Try loading it with most recent Slicer Preveiew Release.

If that does not work either then please provide us an example image. Preferably image some object of known size (not patient image), to avoid patient privacy issues and so that we can verify correct sizing. Upload the file somewhere and just post the link here.

Yes, that was the latest preview.
The study contains all kinds of files!
.MVL
.3DH
.BMP
.CNE
and files without extension which I assume are the dicom files.
The DICOM files size is about 2.3 Meg.
I tried the .MVL files, but all I got was horizontal lines!
I will try removing personal data and put the folder on google drive and share it later!

Best regards,
Jabbar Ali

Thank you very much for your reply!
I forgot to add a link to the MVL file I used in that screenshot!
Here is the link:
https://drive.google.com/file/d/1pG72s4rrLHN1T167HsakNsy8cl6bNbZE/view?usp=sharing
I really appreciate your help!

You can find instructions for loading Samsung mvl files here: New extension: RawImageGuess - for loading of images from unrecognized file format

Thank you very much!
Yes, I do have this extension, It gives same results like in the screenshot.
Jay

Thanks a lot!
I am sure you are aware of this software.
Searching on the internet, I found this website:


I wonder, how did they manage to open MVL files?
Thank you,
Jay

You can load these files with a few minute of work (as shown in the RawImageGuess module demo video).

If you want to access these files more conveniently then you can find a student or developer who can analyze the file format and develop a reader for it with a few days of work (it is much faster if you can get the file format specification from Samsung). You can also buy BabySliceO, but as far as I know it it costs a few thousand $ and it cannot export the file into an open format, so you can only view/process it in that software.

I really appreciate your efforts, thank you very much!
I just want to know if the mvl files I have worth the effort, I don’t know if they have the necessary information to generate a 3d model!
I watched the demo video and tried myself, but couldn’t reach anywhere!
Were you able to download the MVL file?
https://drive.google.com/file/d/1pG72s4rrLHN1T167HsakNsy8cl6bNbZE/view?usp=sharing
Thank you again
Jay

You can load the volume with these parameters (I determined by moving the sliders one by one, as explained in the video):

You can load the image very easily by placing the header file that RawImageGuess module generates (SingleVolume.nhdr) into the same folder as your image file (1.mvl) and drag-and-dropping this header file on the the Slicer application window.

1 Like

Mr. Andras,
You are very talented! I am so glad that my file really has information.
I did reach the 512 value on the x dimension, but could not determine the rest!
I will try with different files and see where I can reach!

I have contacted Samsung and asked for a viewer to open the MVL files, their USA representative promised to help.

1 Like

I’ve also found a 4D sequence in the file (you can read it with Movie4D.seq.nhdr header):

SlicerCapture

1 Like

Amazing!
My wife is the sonographer, I am a mechanical engineer, I am trying to 3d print the babies, but it is a really long process for me!
Again, That is an amazing work an relatively short time!

Ultrasound image segmentation is hard, as there is lots of noise in the image and surfaces are blurry. Also, the images are usually incomplete due to acoustic shadowing and limited field of view.

That’s why professional baby 3D printing services employ artists, who warp existing generic baby 3D models to the surface patches visible on ultrasound. This way they always get a full and realistic image, with visible details taken from the actual baby. This is not an easy skill to learn and it involves image segmentation (in 3D Slicer) and 3D modeling (Blender, Rhino, etc.), but the results are amazing.

I was following this video


But at segment editor, I couldn’t find “Create surface”
Is it not available in the latest version? Or, probably moved somewhere?

Thank you!

That video is almost 3 years old. THe button now says “Show 3D”.

Thank you very much!

Best regards,
Jabbar Ali

But, why are steps after create surface which is now show 3D, these steps do not work! I couldn’t see a 3d similar to the video and also was not able to use, or get results from, for example, scissors, Erase and so on??
Thank you,