Segment Editor functions don't work past specific slice in DICOM series

Hello all,

I’ve been spending the last few weeks segmenting skull bones using CT skull DICOMs for research purposes. I got a fantastic solution with the help of the users of this forum last time - my current problem is a little bit simpler.

On this specific DICOM series, when I use the segment editor the functions stop working after a specific image in the axial series. Threshold indicates that it wants to fill in the entire series but when I run the function, it is only partially filled. Manually painting the volume at any image in the unresponsive section doesn’t work either. I have no annotations currently active and never cropped the volume to begin with. Couldn’t find a thread with an equivalent problem after searching, so posting it here.

Screens:


Here you can see that the threshold I did stopped at a specific axial slice.


This is the preview when I am applying a threshold to my segment - you can clearly see the problematic sections are included and this is true for the entire series.


My attempt at painting above the problematic slice - didn’t change anything.


Volume information if this helps - it’s a solid volumetric scan but not anything out of the ordinary.

Any help would be appreciated! Thank you all so much.

You can only paint within the extent of the “binary labelmap representation”. You can specify a larger extent by selecting a different node (e.g., the volume that contains the complete skull) and use it as source geometry (see some more information here).

1 Like

You probably have the same issue as this thread:

See this info: https://www.slicer.org/wiki/Documentation/Nightly/FAQ/DICOM#Image_is_stretched_or_compressed_along_one_axis

1 Like

this was the one! the node somehow was switched to a smaller view, redefining the source geometry fixed it. Thank you so much!

1 Like