Segment editor tools

Operating system:mac os 10.15.5
Slicer version:4.11.0
Expected behavior:
Actual behavior:
Im new to the slicer app , just started the summer course, yesterday in the course showing the segment editor, i had fewer tools than the instructor, who suggested that the problem with the slicer morph extension installation
i removed and reinstalled it but it didn’t work
will this affect today’s topic mainly using SlicerMorph including landmark-based geometric morphometrics, GPA module

OR is there is a method to check if the installation process is correct

Thanks

If you have any doubts that extensions are successfully installed, uninstall them, and reinstall. Wait until you are asked to install additional dependencies and choose to install all of them. To make sure they are all completely installed, wait 5 minutes before restarting Slicer.

Several extensions add more Segment Editor effects - see Segmentation category on the Extension Manager. The most important ones are SegmentEditorExtraEffects and SurfaceWrapSolidify extensions.

i tried uninstall and reinstall extensions, still don’t have the whole list of tools for the segmentation, im trying to practice how to segment teeth from one of your answers here Teeth Segmentaion
in which a water shed effect is required which i don’t have

thank you for your reply

What errors do you see in the Python console?

Python 3.6.7 (default, Aug 9 2020, 23:06:58)
[GCC 4.2.1 Compatible Apple LLVM 10.0.0 (clang-1000.11.45.5)] on darwin

/Applications/Slicer.app/Contents/lib/Python/lib/python3.6/site-packages/pandas/compat/init.py:120: UserWarning: Could not import the lzma module. Your installed Python is incomplete. Attempting to use lzma compression will result in a RuntimeError.
warnings.warn(msg)

This warning should not be an issue. Could you send the full application log (menu: Help/Report a bug)? If it is too long then you can upload it to somewhere and just post the link.

[DEBUG][Qt] 20.08.2020 15:32:48 [] (unknown:0) - Session start time …: 2020-08-20 15:32:48

[DEBUG][Qt] 20.08.2020 15:32:48 [] (unknown:0) - Slicer version …: 4.11.0-2020-08-08 (revision 29260 / 47c2915) macosx-amd64 - installed release

[DEBUG][Qt] 20.08.2020 15:32:48 [] (unknown:0) - Operating system …: Mac OS X / 10.15.6 / 19G2021 - 64-bit

[DEBUG][Qt] 20.08.2020 15:32:48 [] (unknown:0) - Memory …: 8192 MB physical, 2048 MB virtual

[DEBUG][Qt] 20.08.2020 15:32:48 [] (unknown:0) - CPU …: GenuineIntel Intel® Core™ i5-4288U CPU @ 2.60GHz, 2 cores, 4 logical processors

[DEBUG][Qt] 20.08.2020 15:32:48 [] (unknown:0) - VTK configuration …: OpenGL2 rendering, Sequential threading

[DEBUG][Qt] 20.08.2020 15:32:48 [] (unknown:0) - Qt configuration …: version 5.15.0, with SSL, requested OpenGL 3.2 (core profile)

[DEBUG][Qt] 20.08.2020 15:32:48 [] (unknown:0) - Developer mode enabled …: no

[DEBUG][Qt] 20.08.2020 15:32:48 [] (unknown:0) - Prefer executable CLI …: yes

[DEBUG][Qt] 20.08.2020 15:32:48 [] (unknown:0) - Application path …: /Applications/Slicer.app/Contents/MacOS

[DEBUG][Qt] 20.08.2020 15:32:48 [] (unknown:0) - Additional module paths …: /Applications/Slicer.app/Contents/Extensions-29260/Auto3dgm/lib/Slicer-4.11/cli-modules, /Applications/Slicer.app/Contents/Extensions-29260/Auto3dgm/lib/Slicer-4.11/qt-scripted-modules, /Applications/Slicer.app/Contents/Extensions-29260/SlicerMorph/lib/Slicer-4.11/qt-scripted-modules, /Applications/Slicer.app/Contents/Extensions-29260/SurfaceWrapSolidify/lib/Slicer-4.11/qt-scripted-modules, /Applications/Slicer.app/Contents/Extensions-29260/RawImageGuess/lib/Slicer-4.11/qt-scripted-modules

[DEBUG][Python] 20.08.2020 15:32:49 [Python] (/Applications/Slicer.app/Contents/lib/Python/lib/python3.6/site-packages/pydicom/datadict.py:432) - Reversing DICOM dictionary so can look up tag from a keyword…

[WARNING][Qt] 20.08.2020 15:32:56 [] (unknown:0) - libpng warning: iCCP: profile ‘ICC Profile’: ‘CMYK’: invalid ICC profile color space

[CRITICAL][Stream] 20.08.2020 15:32:57 [] (unknown:0) - /Applications/Slicer.app/Contents/lib/Python/lib/python3.6/site-packages/pandas/compat/init.py:120: UserWarning: Could not import the lzma module. Your installed Python is incomplete. Attempting to use lzma compression will result in a RuntimeError.

[CRITICAL][Stream] 20.08.2020 15:32:57 [] (unknown:0) - warnings.warn(msg)

[WARNING][Qt] 20.08.2020 15:32:57 [] (unknown:0) - libpng warning: iCCP: known incorrect sRGB profile

[DEBUG][Python] 20.08.2020 15:32:58 [Python] (/Applications/Slicer.app/Contents/lib/Slicer-4.11/qt-scripted-modules/SubjectHierarchyPlugins/AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: Annotations

[DEBUG][Python] 20.08.2020 15:32:59 [Python] (/Applications/Slicer.app/Contents/lib/Slicer-4.11/qt-scripted-modules/SubjectHierarchyPlugins/AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: SegmentEditor

[DEBUG][Python] 20.08.2020 15:32:59 [Python] (/Applications/Slicer.app/Contents/lib/Slicer-4.11/qt-scripted-modules/SubjectHierarchyPlugins/AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: SegmentStatistics

[DEBUG][Python] 20.08.2020 15:33:00 [Python] (/Applications/Slicer.app/Contents/lib/Slicer-4.11/qt-scripted-modules/SubjectHierarchyPlugins/AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: ExportAs

[DEBUG][Qt] 20.08.2020 15:32:59 [] (unknown:0) - Switch to module: “Welcome”

[DEBUG][Qt] 20.08.2020 15:33:10 [] (unknown:0) - Switch to module: “SegmentEditor”

Thank you for the logs. It seems that SegmentEditorExtraEffects has not been installed. Path of SurfaceWrapSolidify extension shows up, but it does not appear in the Segment Editor. Please install yesterday’s Slicer Preview Release from https://download.slicer.org/?offset=-1 and install SegmentEditorExtraEffects extension and let me know if the additional effects show up in Segment Editor.

Hi
it worked, i can see the additional effects now, time to practice
thank you :slight_smile:

1 Like