Setting up the segmentation volume for extract centerline module

Hello Everyone,

I have a segmentation volume shown in the image below, created after processing an image stack by pixel classification. I want to use this volume for creating a network model in the extract centerline module.

However, the presence of tiny sharp endpoints (circled black) creates an issue while trying to use Autodetect for detecting endpoints post which the network model can be created.

I would like to know if it is possible to use any of the options available in the segment editor to remove these sharp surfaces after reconstruction of the 3D volume.

You can use Smoothing effect in Segment editor. You can also try preprocessing your input image before segmentation using filters in Simple Filters module. It may also improve your segmentation quality if you resample the image before segmentation to have isotropic voxels, using Crop volume module (as some of the structures look suspiciously flat).

Hi @lassoan

Firstly, thank you very much for always taking the time to guide me throughout this journey.

Í’m afraid I don’t know which filter has to be chosen In the Simple Filters module from the many options that are listed.

I am sharing the stack (here) that I wish to preprocess for your kind reference.

Could you please suggest which filter would be appropriate? I’m looking for an option similar to imopen in MATLAB (erosion followed by dilation) to remove these small objects in the borders of an image. I’ll be really happy to know if there are other suggestions.

Sure, I’ll try this too.

This exact algorithm is available in Segment Editor, Smoothing effect, opening method.

ITK filters are documented in the ITK software guide. Search for “smoothing”.

Thank you, I tried to use Smoothing -> Opening for the default kernel size, and it results in the following segment unfortunately

I’d a chance to look at the smoothing filters chapter of the documentation. Unfortunately, I still do not completely understand how those operations differ from the smoothing option available in segment editor > smoothing .

Probably the segmentation’s resolution is just not fine enough to remove such small noise from it. You can try oversampling the segmentation or apply more surface smoothing. You can probably also find out from vessel network extraction results which endpoints correspond to very short branches, remove those endpoints, and rerun the network extraction.

Hi @lassoan
For what has been suggested, I’m trying to set up the crop volume parameters.

I’ve selected nearest neighbor as the interpolator and I am not sure how the Spacing scale has to be adjusted. I think the spatial resolution of the original volume has to be increased. To increase the resolution , I tried a spacing scale of 0.5. I would like to confirm on this.

The simplest way to resample (and also at the same time crop the volume to the minimum necessary size, to avoid blowing up your memory usage) is to use Crop volume module.