Slicer - black screen when opening stls or nrrds

I’m having problem with Slicer. When importing stl or nrrd (drag’n drop or import) the programme shows only black screens. Literally nothing happens.
Another thing is that I don’t know how to install sequences extension.

Installing done :smiley: But nrrd problem stayed.

Sounds like this kind of issue:

Installed newest drivers for nvidia mx250. It’s a laptop (MSI PS42 8RA).

Nothing’s changed :frowning:

Tried with samples from embodi3d as well as with official slicer samples.

As for the guy who had 4 black rectangles - I see 3 with 4th being the pink cube.

Dicoms work fine.

This means that it is probably not an OpenGL issue then.

STL files only supposed to show up in the 3D view by default. Click in the 3D view and click the small rectangle icon to center the view to the scene content. You may also hit r key to reset zoom.

nrrd files should show up in slice views. You can go to Volumes module to check if the file was loaded correctly (has reasonable dimensions and range of values).

I received the images from @Mikolaj and they were all loaded without issues. The two nrrds and models are all at different locations - you need to click the center field of view to make sure they show up in the selected view.

Installed new 4.11 slicer - makes no difference :confused: Center or not, it just doesn’t load the files.

Checked on my friends 'kintosh - all works well there, and according to your instruction - one of the objects was waaaay out of the box :smiley:

slicer problem 2

Oh, I see your screenshots now. Files cannot be loaded from folders that contain special characters. ASCII maybe Latin1 characters are safe, but many Polish characters are not. Rename the parent folders or move your files to a different directory. I’ve submitted an issue to improve Slicer in this (at least display a meaningful error message).

1 Like

Thanks Andras!
That solved the problem :D. Main user name also had special characters so… only main directory

Big Thanks!

1 Like