Slicer-DeepSeg issue

Hello, All members in 3D-Slicer

Maybe… Have you ever used the Slicer-DeepSeg extension?

I’m reproducting extraction of brain tumor using Slicer-DeepSeg extension based on 3D-Slicer.

I’m running DeepSeg extension using MICCAI_BraTS2020_TrainingData in 3D-Slicer refering to Slicer-DeepSeg github.

I ran the Slicer-DeepSeg extension in 3D-Slicer as following.

  1. Creation of Slicer-DeepSeg Extension/DeepSeg module
    1)I run ‘Extension Wizard’ module->2)Select ‘Select Extension’ button->3)Select ‘Slicer-DeepSeg’ folder-> 4)Select whether ‘DeepSeg module’ loads or not

  2. I downloaded dataset

  3. I run DeepSeg module using MICCAI_BraTS2020_TrainingData in 3D-Slicer
    (1) After pressing ‘Add Data’ button in ‘Welcome to Slicer’ module, I imported ‘BraTS20_Training_001’ folder in MICCAI_BraTS2020_TrainingData.
    (2) And then I selected ‘DeepSeg’ module in ‘modules finder’ option.
    (3) In Inputs item, I selected ‘BraTs20_Training_001_flair_1’ in ‘FLAIR Volume’ option.
    (4) In Outputs item, I selected one volume (MRI) dicom file in ‘Tumor Volume’
    (5) I set the different options in ‘Advanced Segmentation Parameters’ item as following.:

    • Image Modalities : FLAIR
    • Corrped Image Shape :(192, 224, 160)
    • Tumor Type : Whole Tumor
    • 3D Background Colour : Black

After completing setting using DeepSeg module in 3D-Slicer, I pressed ‘Apply’ button.

But It occurs the error that is “Failed to compute results: Incomplete or corrupted file detected. The sha256 file hash does not match the provided value of 941eb4b2c7da98310a95176e7adabe8f84d2e3df.
Traceback (most recent call last):
File “C:/Users/TRL 3D/Extension_dev/Slicer-DeepSeg/DeepSeg/”, line 603, in onApplyButton modelPath = get_file(pretrainedURL.split(”/“)[-1], pretrainedURL, File “C:\Users\TRL 3D\AppData\Local\NA-MIC\Slicer 5.1.0-2022-07-01\lib\Python\Lib\site-packages\keras\utils\”, line 298, in get_file
raise ValueError(ValueError: Incomplete or corrupted file detected. The sha256 file hash does not match the provided value of 941eb4b2c7da98310a95176e7adabe8f84d2e3df.”.

Please, refer to attached image associated with error massage.

Please, let me know in detail how to solve this problem.

Thank you for reading my writing.

I guess you refer to code from this repository. Best to file an issue there.