Slicer Radiomics error

Hello, I’ve run into the following error with both nightly and stable releases of Slicer, on a Mac. Same error when I tried at work, on Windows, with both nightly and stable release, although I’m not able to poke around the installed software at work as much as I can at home.

RadiomicsCLI standard error:

Traceback (most recent call last):
  File "/Applications/Slicer 4.11.2 Stable .app/Contents/Extensions-29402/SlicerRadiomics/lib/Slicer-4.11/cli-modules/", line 7, in 
    from radiomics.scripts import parse_args
  File "/Applications/Slicer 4.11.2 Stable .app/Contents/Extensions-29402/SlicerRadiomics/lib/python3.6/site-packages/radiomics/", line 15, in 
    from . import imageoperations
  File "/Applications/Slicer 4.11.2 Stable .app/Contents/Extensions-29402/SlicerRadiomics/lib/python3.6/site-packages/radiomics/", line 6, in 
    import pywt
ModuleNotFoundError: No module named 'pywt'

No improvement after I uninstalled and reinstalled python and pyradiomics (via pip, including all the prerequisites it seems)

I’m not the most tech savvy but I know to find that I have Python 3.8.6 installed.

Thanks for any help,

This appears to match the reported error that another user reported over at the SlicerRadiomics github repo

cc: @JoostJM @fedorov

Yes, we discussed this with @jcfr today, and if I understood correctly, something has changed on the factory machine about 27 days ago, which broke packaging of the pywt extension. JC was going to change something on the factory to fix this.

In the interim, I was able to make the module work again by manually installing the missing packages from the Slicer python console:

>>> slicer.util.pip_install('pywavelets')
>>> slicer.util.pip_install('python-dateutil')
1 Like

The issue is that pywavelets is installed in the main Slicer build tree and this prevent the package from being packaged into the extension.

I manually deleted the package from the site-packages in the build tree associated with the latest stable build.

We will re-assess tomorrow.

1 Like

Yesterday I added a fix to check for missing modules and install if they are not present. Please check the latest stable build and let us know if the issue is not resolved.