Slicer Tractography ROI Selection Not Working

Hi. I’ve been following the Slicer tutorial: 5.1.6 Fiber Bundle Volume Measurement

When I try to run tractography ROI selection, I get the following error:

Tractography ROI Selection standard error:

dyld: Library not loaded: /Volumes/Dashboards/Support/qt-everywhere-build-5.10.0/lib/QtSql.framework/Versions/5/QtSql
Referenced from: /Applications/
Reason: image not found

I’ve tried redownloading the SlicerDMRI extension, but nothing’s worked so far.

Hi. Could you please try SlicerDMRI in the Slicer release version (4.10.2) and let us know if this works for you?

There is some rapid development happening in the Nightly Preview version so it’s possible something has broken. It looks to be related to Qt, and possibly not directly caused by SlicerDMRI. Did any other modules not work for you in the Preview version?

Hi there! I tried it in the 4.10.2 version as well as the 4.11.0 version but I had the same error message.

Thank you. Could you please help us reproduce this by letting us know which page of the tutorial you are on and what dataset you used?

I confirm that I got the same error running the CLI with SlicerDMRI on mac with 4.10.2. It appears to be an extension linking/packaging issue (like SlicerDMRI links to the SQL library but that is not included in Slicer’s distribution). @jcfr do you have any ideas?

1 Like

@cindy if you have access to a windows machine the same module does work there (4.10.2 SlicerDMRI, probably works on linux too but I didn’t test).

Thanks for letting me know. Looking into it and will report back shortly.

1 Like

It worked for me on Windows! Thanks @pieper

A regression was introduced back in December. The following PR should fix the problem for Slicer preview build.

Once we confirm it works well for the Preview extensions, I will backport the fix into the Slicer 4.10 branch and locally apply the change on the build machine.

Update: Corresponding changes have been integrated into both Slicer and the maintenance branch for Slicer 4.10. Change to the extension build system for Slicer 4.10 have also been applied locally on the build machine.

Extensions made available tomorrow through the extension manager should be valid.


Thanks very much @jcfr!

1 Like

thank you!! this worked for me this morning.

Hi @jcfr thanks for the fix. The night version works form me, but the Stable Release 4.10 still has the issue: “dyld: Library not loaded: /Volumes/Dashboards/Support/qt-everywhere-build-5.10.0/lib/QtSql.framework/Versions/5/QtSql”.


Could you check you are using 4.10.2 and not 4.10.1 ?

Hi @jcfr

I confirm that I was using 4.10.2. I just installed Slicer 4.10.2 again. It gave me the same error.

But, after looking into the error, I found that the newly installed 4.10.2 was trying to call a lib from another Slicer (4.10.2) installed on my computer. After I removed the old 4.10.2, the tract selection module works now. Perhaps, this is an issue that you have noticed?

Thank you!!!



All extensions are shared between all Slicer installations of the same version of the current user. You need to update (or uninstall and install) the extension to update it (Slicer install/uninstall will have no effect).