SlicerVirtualReality issues

Yes, and these “good VR handles” are the critical part :slight_smile: Because we have everything we need in Slicer, but exposing it in a UI-less environment is the challenge. This is why we have eben trying to make time (and find funding) for such developments in the last three years. Hopefully soon at least the basics will be available!

FYI you don’t need Prism to do box cropping. What you need Prism for are the custom GPU shaders that for example allow sphere cropping, and a lot more things too.

I’m doing the same thing, except using occulus link (via cable) instead of airlink. I assume that has identical functionality other than how the link is physically created.

When I get to your last step, I am floating in the empty space, except my segmentation is nowhere to be found. I’ve pressed the joysticks back and forth but I never see anything except empty black space.

Ran into a similar problem when I tried to open a volume rendering - they seem not to be functional in VR at the moment. After doing a thresholded bone segmentation you need to activate it in 3D view (segment editor), then switch to Slicer VR and press the VR headset symbol - this should work in Slicer 4.11 as of May 10th 22.

Volume rendering not working: Please see my comment above for the current state of SlicerVR.

If you use a Slicer Preview version older than mid-February then volume rendering will work. It was broken with the update of VTK under Slicer on February 24 (if I remember the day correctly).

1 Like

I just tried the 2-2-22 version of 4.13.0 and I still can’t visualize a volume render in slicerVR.

Two ideas:

  1. Try an even older version, maybe I remembered wrong.2. In Volume Rendering module, in the Inputs section, make sure that in the Views combobox not just the 3D view but the VirtualReality view is checked as well

This is what I see for views box:
image

Edit - after I turn on slicerVR, I do see a view1 option AND a virtualrealityview. They are both checked.

When you start VR, then a second option for the new VR view will show up, which needs to be checked in order for the volume rendering to show up. Note that this step should not be done every time, but sometimes it occurred to me that it was unchecked and had to be checked manually.