Thresholding Failing in Nightly Build

I am working on a windows 10, and have the latest nightly build from today. When I import my volume and then import a labelmap, convert it to a segmentation node, and attempt to threshold the volume, the segmentation fails (it only segments a small patch of the spine (my threshold is set at 134.63 and should be segmenting the couch and all bone). The first image is what should be thresholded, while the second is what is actually getting thresholded. image image

The extent of an existing segment will not change. What happens if you try thresholding on a newly created segment?

Just tried adding an additional segment, and the same thing happened. It’s still not thresholding past the vertebrae.

The only time it seems to work is if I create a new segmentation, threshold the DICOM, then drag and drop the segments into the new segmentation.

As @cpinter wrote above, segment extents are not modified automatically. You can adjust extents by clicking on the segmentation geometry button (next to volume selector).