Unable to download 3D SLICER 5.2.2 for windows

For a week I’ve been trying to download the software from this page : https://download.slicer.org/
the download starts and stops suddenly and shows me “unable to download”
Any solution that can help me ?
Thanks in advance

It sounds like a network issue between you and the server. Downloading works for me both on my local workstation and from various cloud compute instances.

I have run into this issue myself several times with attempting to download Slicer, even earlier this week. Whenever I tried to download from Windows (various Browsers and at command line with PowerShell) I noticed the same thing, goes for a bit at high speed, throttles down, then quits.

I was eventually able to download on my Mac (from the same network), so I’m wondering if it’s something on Slicer’s server side, or something else with its geophysical hosting. I’m downloading from North America if that helps, over standard residential internet.

Thanks for reporting. If others have the same problem please report and maybe we can get to the bottom of the issue.

I’ve tried from Eastern Canada when I saw the post, the download was completed in about 30 seconds.

Please write here if you encounter any problem again (with the exact time when it happened) and we’ll test immediately.

@jcfr can you see errors in the server logs?

We will be reviewing the log and follow up.

1 Like

server: download.slicer.org server

Based on the access and error logs associated with download.slicer.org for the period of April 8th to April 14th.

We couldn’t identify any outstanding issues.

That said, reviewing the 500 errors helped identify some interesting attempts to gain privileged access, we will follow up with details.


$ cat access.txt.* | cut -d '"' -f3 | cut -d ' ' -f2 | sort | uniq -c | sort -rn
 107416 200
  11365 302
  10406 404
    511 400
    139 502
    122 499
     64 405
     58 301
     49 206
     24 304
     13 500
$ cat error.txt.* | wc -l
$ cat error.txt.* | ack "SSL_do_handshake\(\) failed" | wc -l
$ cat error.txt.* | ack "Connection refused" | wc -l

server: slicer-packages.kitware.com

This is the server from which both application and extension packages are effectively downloaded from.

The downloads may be originate from the download.slicer.org site or from the extensions.slicer.org presented to the user through the extensions manager.

We will shortly provide a report.

1 Like