View/save NODDI output

how do i look at and save the NODDI intra-cellular and volume fractions. are they imbedded in the vtk? how to view?
do i need to run the UKF before NODDI? seemed to successfully complete directly…here is the error free comand:

UKF Tractography command line:

/home/toddr/.config/NA-MIC/Extensions-25993/UKFTractography/lib/Slicer-4.7/cli-modules/UKFTractography --dwiFile /tmp/Slicer/IEAC_vtkMRMLDiffusionWeightedVolumeNodeB.nhdr --seedsFile /tmp/Slicer/IEAC_vtkMRMLLabelMapVolumeNodeC.nhdr --labels 1 --maskFile /tmp/Slicer/IEAC_vtkMRMLLabelMapVolumeNodeB.nhdr --tracts /tmp/Slicer/IEAC_vtkMRMLFiberBundleNodeB.vtp --seedsPerVoxel 1 --seedFALimit 0.18 --minFA 0.15 --minGA 0.1 --numThreads -1 --numTensor 2 --stepLength 0.3 --Qm 0 --recordLength 0.9 --maxHalfFiberLength 250 --Ql 0 --Qw 0 --noddi --recordVic --recordKappa --recordViso --Qkappa 0.01 --Qvic 0.004 --Rs 0 --sigmaSignal 0 --maxBranchingAngle 0 --minBranchingAngle 0

Since you saved them using --recordViso and other record flags, they will be stored in the vtk file. Please see the tutorial on “Slicer Fiber Bundle Selection and Scalar Measurements tutorial” here for information on how to extract these measures into a spreadsheet:
If instead you would like to visualize the measures, you can do this in Tractography Display.

Thanks for the links, tractoghphy display has all advanced options disabled. So selecting vol fraction and lit in pull down like FA for tensor fit isn’t available.

Hi please let us know more information. For example which version of Slicer you are using? Are you able to use the top panel of tractography display and does the vtk file show on this menu? Have you both loaded the vtk as a Fiber Bundle and also installed SlicerDMRI?

using 4.7.0-2017-04-29 with all the diffusion extensions enabled, under tractography i do not see the fibertract scalar measurements option. looks like they all require a tensor to function. how do i set the interface noddi to create volumes directly?

Hi please share a small example vtk file if possible so I can take a look. I do not know why the advanced display would be disabled. Does this happen also for other tractography vtk files? Has it happened in other versions of Slicer?

The scalar measurements should be under Quantify->Tractography Measurements. This module is to make quantitative measures (e.g. mean of all values stored in tracts) not to visualize.

The UKF tractography module does not produce volumes, just fiber tracts.

looks like you are missing --recordTensor?

Does this indicate the advanced options are disabled if tensors are missing? This does not make sense with other models such as NODDI, or even with tensors because still other values are often stored along the tracts.