Visual regression in Volume Rendering

Today’s build has introduced a visual regression while rotating a 3D model in Volume rendering. A new VTK commit has been pulled in. It seems to request a too high frame rate. Please see two screen video shots with Slicer commit tags as suffix :!BVlBwTqL!FGXzin-WlSKl6uhENQFlaw_4-PRidRL45oJb138-q_A!NR9UAb6B!tbqFNC4ZnJtOs212JcGfU28m7rR5Pn9RkwFq0H2CUVw


For a few weeks we’ve made static-quality rendering the default, a few days ago we reverted the default to the previous progressive (adaptive) option to have interactive frame rates by default for CPU volume rendering and for virtual reality viewing.

You still have all the options available. To prevent low-quality rendering during rotation, then go to Advanced settings / Techniques tab and either decrease “Interactive speed” or switch to “Normal quality”.

To reduce wood grain artifacts, I would recommend to enable “Surface smoothing” or (if rendering time is not a concern) then use “Maximum Quality” setting.

Let us know which settings work well for you. We may tune default values based on what we hear back from users. We also plan to make defaults adjustable in application settings.

‘Normal quality’ renders as previously experienced. It would be great to have it adjustable in application settings, as well as ‘Surface smoothing’., for a more comfortable workflow.

I’m planning to add this feature next week.

1 Like