Volume rendering slow in latest nightlies for MacOS

I integrated the changes in Slicer core, tomorrow’s nightly should include these. Basically the LockSampleDistanceToInputSpacing option is now on by default in Adaptive mode, but Maximum quality mode is the same. The jittering option is exposed on the UI, in advanced rendering properties (when using GPU).


Built commit 12806744f on Arch Linux (VTK9). I just want to confirm the huge visual performance gain in Volume Rendering, when moving around the model. Even my low powered AMD Kaveri iGPU renders quite nicely via HDMI on a Full HD wide TV screen. It has never been that good !