[notes] CDN problem on umich.edu eduroam network


(Isaiah Norton) #1

Some users at University of Michigan cannot access the Discourse CDN for some site resources. Here’s a debugging conversation (I followed up by email up from this topic).

They can’t connect to these other Discourse sites either:

https://talk.jekyllrb.com/

They see a browser error loading resource, and can’t ping the CDN. Does this ring any bells?


(user):

On my side, I tried with Safari and Chrome and I have the same result. I can open discourse.org and the other hosts I tried.

What happens is the web page loads first the text in a browser tab:

Then the page stays blank and after few minutes it sends a timeout error in the chrome console:


(me):

Ok, that helps to narrow it down a little bit. Can you ping discourse-cdn-sjc1.com/standard2? Is there any ad-blocker installed on these computers? There’s a bug report that sounds kind of similar, where some software was blocking the Discourse CDN due to false positive:

https://meta.discourse.org/t/discourse-cdns-are-blocked-by-privacy-badger/17127/17

Might be happening on your network if they use a similar heuristic or list.


(user):

That ping is not working.

There is an ad-blocker in my Chrome but not in Safari, and I tried to disable the ad-blocker and the issue is still the same.

Then, why can I access the website with my smartphone on the same network, would it be linked to the browser?


(me):

Since you can’t ping the CDN at all, it’s probably not the browser. That seems like it might be a block at the institution level (since you said multiple computers), or at least local firewall.

I think the ones I originally linked are mostly business hosting, so they might be hitting a different CDN. Can you try these, they’re on the same plan as Slicer and hits a similar CDN for me:

https://talk.jekyllrb.com/
https://discourse.ros.org

Then, why can I access the website with my smartphone on the same network, would it be linked to the browser?

Assuming you are connected to wi-fi, but also have cell service, maybe it falls back to unblocked cell network if a request fails – I’m not sure what the request resolution rules are on various phones.


(user):

When we tried on laptops, we used eduroam, so not really specific. But, on the computers plugged on the department wifi it’s working fine.


(me):

Ok I missed that the first time: so just to clarify

  • the problem is only on the wifi network called eduroam?

I think you need to contact the university IT in this case – looks like "4HELP@umich.edu" (from the site above). I don’t think there is much Discourse can do if the CDN is blocked on that specific wireless network. From what I can tell, eduroam is just an authentication provider, so university IT controls the configuration.

It looks like someone else saw weird issues with eduroam too, but no follow-up on any resolution:

https://meta.discourse.org/t/mobile-clicking-create-new-account-causes-processing-spinner-icon-to-keep-spinning/55508/15


(Isaiah Norton) #2

(user):

I tried with MWireless and eduroam => not working but with MGuest => working. So, the solution is to contact IT or to switch to a non-blocking network to access the discourse.

So, they are going to follow-up with university IT, because there is nothing we or Discourse can do about local network settings.